The dreaded "Grant File Access" in PowerPoint

I have an applescript written years ago that worked fine until an upgrade to the Mac OS. Now when I run the script, it asks for permission to access the files being imported. There are over 500 files so I would like to avoid having to press Enter 500 times. I know of one person that puts a stapler on the return key just to run the script! Is there a way of getting around Sandbox? Searching the internet, someone suggested converting the path to an alias object and making sure the command is outside of the 'tell application' block. I've tried this (below) with no luck. Does anyone have any other suggestions?

BTW: Someone suggested that the Documents folder was not affected by sandbox and said to try putting files there. This didn't work. Thanks.

Answer
Answer

Hi Mike,

First of all, you mentioned the issue occurred after Mac OS upgrade, I would like to suggest also contacting Apple support to check the Apple Script affected by sandbox. 

Here, based on my research, could you please try putting files in the location below?

/Users / (YourUsername) / Library / Group Containers /UBF8T346G9.Office

If the issue still occurs, could you please share with us a screenshot of the error message? Is your Mac OS version 10.14.2 and PowerPoint version 16.20 (PowerPoint > About Microsfot PowerPoint)?

Regards,

Tina

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated April 9, 2021 Views 3,780 Applies to: