Attempting to open links in Outlook 2013 in any email to any website yields an error that says "something unexpected went wrong with this URL: (INput URL). Class Not Registered

As the title states -- I am unable to open any links in Outlook 2013.

All links that I click on provides me with an error stating:

"Something unexpected went wrong with this URL: "http://blahblahblah" Class not registered.


how do I go about fixing this solution?

Thanks
 

Question Info


Last updated March 12, 2019 Views 24,681 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hello Allan,

 

As per the description provided, it looks like you are not able to open hyperlinks in Outlook.

 

Before we proceed I would require some more information to assist you better.

 

Which is default browser set-up on the system?

 

Make sure Internet explorer is set as default browser and then try opening hyperlinks in Outlook.

Refer to the following link to make Internet explorer default browser:

http://windows.microsoft.com/en-IN/internet-explorer/make-ie-default-browser#ie=ie-10

 

If issue persists, reset Internet Explorer by running the Fix it in the following article and verify the results.

http://support.microsoft.com/kb/923737

 

Note: The Reset Internet Explorer Settings feature might reset security settings or privacy settings that you added to the list of Trusted Sites. The Reset Internet Explorer Settings feature might also reset parental control settings. We recommend that you note these sites before you use the Reset Internet Explorer Settings feature.

 

I hope this helps. If you need any further information, you can always reply and I’ll be happy to help you.

 

Thank you

36 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have been looking for a solution to this technical error for a while now, then I remembered there was a client of ours that had this same issue for Outlook 2003! The fix for 2003 also works for 2013!

http://support.microsoft.com/kb/310049

 

IT Consulting in Phoenix

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having the same issue with a fresh install of Office 2013 on a Windows 7 64 bit OS, Office 2013 32 bit, with IE 8 as the default browser.  All PCs in the company (60+) do not have this issue.  I attempted the fix for office 2003 but that did not work either.

*********UPDATE*************

07/22/2013

What I finally did was completely rebuild the system and the issue was resolved.  For me, this was the solution because I had other build problems occurring at the same time.  Not sure if they were related but everything is working now.  I know this will not resolve the issue since it is impractical for most users.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I WANT TO USE FIREFOX AS MY DEFAULT BROWSER. HOW DO i FIX THIS?
I hate IE and I hate this new one even more. It is too bossy and solicitous, I don't want to be strong armed into using it by you guys messing with my choices!!!!!!!


I am in tears over this!!!!! Having to write and beg you for help!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having the same problem. I also use Firefox as default browser.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just to BUMP this thread, I too want to use Firefox as the default browser that opens hyperlinks from Outlook 2013.

No reply seems to be the loud answer from MS Support, is this because they don't like customers using anything other than their software? I.E. is exactly as decribed by a previous poster and it seems others want to be able to utilise a free choice of browser, MS Support however are not supporting these clients.

Please assist, we pay enough for the software after all, some support would be useful.

Thank you in advance.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having a very similar issue:

SETUP:

Windows 7 Pro 64bit. Office 2013 32bit(as recommended by MS). IE11. Active Directory domain. IE connection setup to use a proxy via a pac file.

All was fine until I installed Office 2013. Now, when I click on a hyperlink from anywhere in Windows, I am getting the "class not registered error". This happened in Word, Excel, from the start button, email client, almost anywhere except from within IE. Happens with http://, ftp:// and file://, but not mailto. Happens with htm, html and asp pages. If I change the default browser to Firefox, all works OK. If I reset all IE settings, it works for a little while, then reverts back to the same behavior.

I suspect there may be a group policy setting changing something but I cannot find a setting that could cause this behavior.

Other things I have tried:

Re-registering office components

Doing a repair on Office 2013

SFC /fixnow

Reset IE (works for a little while)

re-register several DLLs

I am stummped

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I got the same problem with Outlook 2013 on Windows 8.1.

In my case the solution is NOT to start Outlook as an Administrator. 

By doing this it solves two problems:

"Something unexpected went wrong with this URL: "..." Class not registered.

- Can't drag and drop email as attachment 

However, not running Outlook as an Administrator, another problem happens is that the PDFMaker add-in can not be enabled.

Microsoft must did a wonderful touch to Windows 8.1 already ;)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This really does not help.  

Many of us do NOT want to use Internet Explorer as our default browser, and I think it should be criminal that you are forcing us to do so in order to make your program work properly...

Am now looking for a different email program to use instead of Outlook, as this is completely unacceptable. 

BTW, I had no trouble with opening links in email until today, and I've always had Chrome as my default browser. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I had a user with this same issue in Outlook 2013. She was running on IE8, so we upgraded her to IE11. All her links are opening now.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.