View in browser opens in IE8 instead of Firefox

I added View in Browser to my Outlook message Quick Access Toolbar.  The detailed tooltip reads "View this item in your default Web browser".

My default Web browser is Firefox 4, but clicking the icon opens the e-mail in IE8. How do I get Outlook to respect my default browser setting and open the e-mail in Firefox instead?

Note: Office 2010 was installed after Firefox, but I've confirmed that Firefox "believes" it is my default browser.
 

Question Info


Last updated December 3, 2018 Views 2,828 Applies to:

Try the steps mentioned below to set Firefox as your default browser and check what happens:

1. On the taskbar, click Start, and then click Set Program Access and Defaults.

2. In the Add or Remove Programs dialog box, click Custom, and then click the arrow to the right.

3. Under Choose a default Web browser, click FireFox, and then click OK.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you, but it didn't work.

I can't set this as a restricted user.

I logged on as Administrator twice, both times found it already set to custom, explicitly set it to Mozilla Firefox, logged off and re-logged on to my restricted user.

Clicking view e-mail in browser still launches IE8 to view in browser to display the e-mail.

Note that when I click a link within an e-mail, it correctly opens the link in Firefox. The incorrect behavior only occurs when choosing to view an e-mail in a browser.

Also note that the only reason that I am trying to view the e-mail in a browser is that Outlook 2010, unlike Outlook 2003, is not respecting my IE8 setting Tools > Internet Options > Accessibility > Ignore font sizes specified on webpages. If it respected that, I would have no need for viewing in a browser. But if I am going to view in a browser, I want to use my default browser.
Charles Belov
SFMTA Webmaster

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

To the best of my knowledge there is no solution for this (i.e. no way to force Outlook to use the default browser).  The only solution I know of is a workaround such as the one here.

http://techniclee.wordpress.com/2012/01/27/open-email-in-default-browser/

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Reviving an old question, but this is the first hit on Google for "view in browser outlook firefox"


Solution:

Tested on Windows 7, Outlook 2013

Go to: Control Panel > Default Programs > Associate a file type or protocol with a program

Find .mht and .mhtml and associate them with Firefox (or other browser).

Now may also be a good time to associate .url and .website

You will need to install a browser addon such as "unMHT" or "Mozilla Archive Format, with MHT and Faithful Save" in order to view the files.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Here's my solution for Windows 8.1 (64-bit) and Outlook 2013:

Take ownership of the following registry keys:

"HKEY_CLASSES_ROOT\mhtmlfile\shell\open\command"

"HKEY_CLASSES_ROOT\mhtmlfile\shell\opennew\command"

"HKEY_CLASSES_ROOT\IE.AssocFile.MHT\shell\open\command"

"HKEY_CLASSES_ROOT\IE.AssocFile.MHT\shell\opennew\command"

Change the value of (Default) in each of those keys to "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" "%1" (including quotes; if you have 32-bit Windows 8.1, change Program Files (x86) to Program Files).

I also installed unMHT, per mattb5906's post above.

Toa Of Justice

"Only the best is good enough."
-Ole Kirk Christiansen, founder of the LEGO Group

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Did not work in WIn 10. Just tried it - changed browser to FireFox - now email does not open at all. Thanks for your help though!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.