Outlook Today script error

I've been running Outlook 2007 on a Windows 7 (Enterprise) computer with no problems for a few years. I've just switched to a different Windows 7 (Home Premium) machine that also had Office 2007 running. I've installed Office 2013 (via HUP) and have successfully moved my .pst file and have synchronized my contacts and calendar from my hotmail account online. The problem:

 

When I start in Outlook Today (or subsequently try to go to Outlook Today from a different view), I get a script error. Line 278. Char 1. Error: "Library not registered." I don't want to disable Outlook Today; I find it to be useful. If I click "Yes" in response to "Do you want to continue running scripts on this page?" everything seems to work correctly, but ...

 

If I try to customize Outlook Today, I get another script error "Library not registered." If I click OK, make a change, and try to save it, I get a pop up in the information bar: "Your web browser has blocked this site from using an Active X control in an unsafe manner. As a result, this page might not display correctly." I also get another script error ("Unspecified error") pointing to the URL "res://C:\Program%20Files\Microsoft%20Office%2015\root\office15\1033\OUTLWVW.DLL/outlook.htm"

 

I've run Repair on Office 2013 (twice), but I still get the error when I start or when I visit Outlook Today. Is there a solution?

 

I intend to upgrade this machine to Windows 8 after I get Office 2013 running correctly.

 

 

Question Info


Last updated September 11, 2019 Views 33,279 Applies to:
Answer
Answer
This is what worked for me only:

Cause:  

  • The registry on this machine contains a key for an older version of the Outlook View Control.  
  • It was leftover from a previous Microsoft Office  installation.

Resolution

  1. Close Outlook.
  2. Open the registry editor by running REGEDIT.
  3. From the highest level, do an export to make a backup of the registry, just in case.
  4. Locate the key: HKEY_CLASSES_ROOT\Typelib\0006F062-0000-0000-C00-000000000046
  5. Within that folder, there will be two keys: 1.0 and 1.1 (1.0 is from an older version of Office,  1.1 is from Office 2010)
  6. Delete the 1.0 key: HKEY_CLASSES_ROOT\Typelib\{0006F062-0000-0000-C00-000000000046}\1.0
  7. Close the registry.
  8. Reopen Outlook 

93 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.