I cannot access my Office 365 mail from Outlook 365 client any more.

Split from this thread.

Hi garethr007,

I cannot access my Office 365 mail from Outlook 365 client any more. This has happened on 2 computers.

I can log into my mail with OWA.

Some suggestions I found and tried.

I have deleted profile on one machine and now cannot connect.

I did a full online repair of Office.

On the second I turned off caching and then back on.

Checked for updates on both computers.

You mentioned 2 step verification.

I just turned on 2 factor authentication for my admin account in my tenant yesterday.

I did not turn it on for the account that I am having problems with.

have there been other issues with 2FA?

Thanks,

Victor

edit:

After I posted, I turned on Multi Factor Authentication on the mail account I am having a problem.

I figured it could not hurt.

So far it has not helped.

Answer
Answer

Hi Betty,

My Apologies for not responding sooner. I was confused about this thread not showing up where I originally posted on someone else's thread.

I see that you forked this and someone else forked the other thread. I was responding to the other thread.

Thank you for suggesting to check the Fiddler logs. This lead me in the proper direction to solve my problem.

Here was my closing post from the other thread. I am also posting here in case it may help someone else.

====================================================

Hi Gabriel,

After some work I was able to get things working.

Thank you for your assistance.

My biggest concern is what triggered this situation.

Was it me turning on the Modern Authentication on in my tenant?

Some notes for anyone that runs across this thread:

I will consider the view that you want to turn on Multi Factor Authentication (MFA) in your tenant.

I do not know if there is a document I did not follow but I went into my security settings in my tenant and enable 2FA for my admin account.

I believe I started having issues with my user account after that. I have NO confirmation from MS about this unless they post a reply about this.

What I do know is that I could not log into my user account and Fiddler showed that Oauth was not turned on. What triggered this I do not know.

Ignoring all the things that did not work. 

Here are my notes on what worked.

NOTE: Read the 2 pages that I have linked. The documentation is good but you have to read it.

I had MFA Turned on in my admin account and my user account.

I then had to connect to Exchange Online using the instructions in:

Connect to Exchange Online PowerShell using multi-factor authentication

 

https://docs.microsoft.com/en-us/powershell/exchange/exchange-online/connect-to-exchange-online-powershell/mfa-connect-to-exchange-online-powershell?view=exchange-ps

 

 MFA requires you to install the Exchange Online Remote PowerShell Module, and use the Connect-EXOPSSession cmdlet to connect.

 

READ THE NOTE at the top of the article. Important information especially if you are a Delegated Administrator.

 

The Exchange Online Remote PowerShell Module needs to be installed on your computer.

Note: You have to use Edge or Internet Explorer to install Exchange Online Remote PowerShell Module.

 

The section on the Windows Remote Management did not work for me. Not sure why, does not seem to matter.

 

Once you are able to connect to Exchange you can follow the instructions on the next link to enable Oauth for the clients to use.

   

Enable modern authentication in Exchange Online

 

https://docs.microsoft.com/en-us/exchange/clients-and-mobile-in-exchange-online/enable-or-disable-modern-authentication-in-exchange-online

 

After you have made all these changes, I made sure I logged out of the account where I could and reboot.

When I logged backed in, my OneDrive connected without issue. I logged into Word and had to confirm the login. To confirm the login I was using the Microsoft Authenticator app on my phone. Very convenient, it just pops ups and asks you to approve or decline. Signed into Outlook without any issue.

Thanks again to Gabriel for your help.

I hope the information helps,

Victor

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated February 14, 2021 Views 297 Applies to: