Outlook Upgrade and "outlook_[letters and numbers]@outlook.com" resolution

OK ...

The office support for the outlook upgrade eff-up on page

https://support.office.com/en-us/article/Reconnect-Outlook-2016-or-Outlook-2013-to-Outlook-com-to-fix-issues-after-Outlook-com-upgrade-cda1751d-9503-40bf-bf76-e79454ac5eb3?ui=en-US&rs=en-US&ad=US

includes:

Known issues after connecting Outlook 2016 or Outlook 2013 to Outlook.com

If you are having issues after reconnecting your Outlook.com account, please see the following links for known issues and workarounds:

Outlook.com email account appears as "outlook_[long series of letters and numbers]@outlook.com" in Outlook for Windows

ISSUE

After connecting to Outlook for Windows (Outlook 2016, 2013, 2010 versions) to your Outlook.com email account, your may experience the following:

  • Your email account name shows up as outlook_[long series of letters and numbers]@outlook.com in the Folder Pane and when composing emails using Outlook for Windows.

  • Recipients will also receive the email from the sender with the outlook_[long series of letters and numbers]@outlook.com format.

  • When recipients reply to the email, the email bounces and you may receive the message “Undeliverable message when you send Internet mail in Outlook.”

This issue only impacts customers using Outlook for Windows. Emails sent via Outlook.com on the web works correctly and emails will be sent with the correct email address.

WORKAROUND

This issue occurs for users with multiple account aliases. We are actively working on a fix. In the meantime, to fix this issue, please do the following:

  1. Go to https://account.live.com/names/Manage and sign in to your Outlook.com account.

  2. Set your Outlook.com email as the primary alias.

  3. Remove any old non-Microsoft account listed as primary alias that you are not using.

  4. In Outlook for Windows, remove and re-add the account. See the steps in this article: Add your Outlook.com account in Outlook for Windows

------------

That occurred in my case, and I followed the instructions and they worked.  BUT, I do NOT want to log into windows et al with anything but my personal email address.  My outlook account is solely and entirely for the calendar shared with my phone.  So ... once the above is completed (and the workaround does work), can I re-add my personal email on the /manage page and set it to primary again?   Or must I wait for MS to come up with a fix "for an issue known and that we are working on"? 

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

To answer your question, you may re-add your personal email.

Keep us posted.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Here's how I fixed this issue in two Outlook.com accounts. Since what I saw and the results were exactly the same, I'd say this is a repeatable scenario.

First you need to check the "From address"s:

1) Log into your Outlook.com email

2) Go to Gear->Connected Accounts

3) Under "From address", select "Change you From address" link

4) Pull down the list of "From address"s, if you see the outlook_<letters and numbers>@outlook.com email address, this fix should work for you.

5) Click Discard

6) Under "Email aliases", click the "Manage or choose a primary alias" link

-Verify account (if prompted)

7) Click "Add email" link

8) In the "Create a new email address and add it as an alias" field, enter a new alias. Doesn't matter what this is, I used my existing *** Email address is removed for privacy *** and added some numbers to make the new address unique, example: *** Email address is removed for privacy ***.

9) Click the "Add alias" button

10) DON'T CLICK ANYTHING ELSE. Open a new tab or window and go back to your Outlook.com email

11) Go to Gear->Connected Accounts

12) Under "From address", select "Change you From address" link

13) The outlook_<letters and numbers>@outlook.com email address should be gone.

14) Open the Outlook application

15) Right click on the outlook_<letters and numbers>@outlook.com and select Remove "outlook_<letters and numbers>@outlook.com"

16) Add the account back to Outlook application (I figure you know how to do this...)

The account should show up in Outlook with the address you had selected as your "From address" and the "From" in a new email should also match the "From address" selected in Outlook.com.

In both cases I already had the email alias selected that I wanted (my specific domain, not outlook.com) before I went through the steps outlined here. If you're using Microsoft's workaround, you'll need to change your "From address" and possibly the primary address before adding the account to your Outlook application.

I hope this is clear enough to help someone.

5 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks for the comprehensive workaround.

I followed the instructions exactly but the crazy address did not disappear. 

As I read your notes at the end you mention having preselected an alias that is not in the outlook.com domain.  To better understand, assume the following:

"From address" is *** Email address is removed for privacy *** on outlook.com

"Primary alias" is *** Email address is removed for privacy *** on outlook.com

The newly created email is *** Email address is removed for privacy *** and it shows up as an alias on outlook.com (but so does the outlook_<letters and numbers>@outlook.com email address.

Any suggestions?

Thanks

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hello,

We just want to clarify few things. Please answer the following:

  • When did you first encounter this issue?
  • Are you able to add your personal email via account.live.com, and set it as primary alias?
  • Did you make any changes on the computer before you encountered this concern?

Please respond back so we can assist you further.

Thank you

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

TL ...

Do it the easy way.  In the MS Office Outlook program (on the desktop etc), drop (remove) any Outlook.com account(s) you have there. 

Exit Outlook. Reboot even. 

Go to Outlook.com and make your outlook.com email address your primary address for logging into Windows and the account. Then remove any other primary non-outlook account from Live/Outlook. 

Reboot, log in using your office.com email address (you do recall the password, right?!!) then restart Office Outlook, ensure any other email accounts you have set up in that program are working properly, and then re-add Outlook as an Exchange ActiveSync account (File > Add Account > Manual Setup > Exchange ActiveSync) .

After that's done, exit Office Outlook, and restart it. 

Your calendar and contacts should be back, and you will have a new entry called *** Email address is removed for privacy *** due to the ost file used by Exchange ActiveSync.  This is where your contacts and calendar live.  If you use your outlook email address for correspondence (I don't), your email will also download into this ost file.

Now try sending mail to and from your Outlook.com account and any other Office Outlook accounts you have set up.   (I keep mentioning this because I have 14 different email accounts set up in Office Outlook, plus the Outlook.com entry for the calendar.) 

If that all works without the funky numbers in any email response address, and you can respond to all your test emails without that occurring, you're in business and you can add back, into Live/Outlook, that former login email address you deleted in step one.    But only if you need or want to use that to log into Windows/Outlook/Live/Office.  If you're happy using your Outlook.com account, then great - you're done!

I did all this, and I have never had a problem after doing so.  Writing this message probably took longer than performing all the steps, too.

Randy

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

There is another workaround to keep the external primary sender address:

1. leave or set the primary sender address in the options of https://www.outlook.com to the *** Email address is removed for privacy *** you would like to use (instead of the @outlook.com).

2. if not already done create a new profile in your windows outlook and automatically setup the office 365 account with your @outlook.com-username so that it shows the wrong outlook_[long series of letters and numbers]@outlook.com as exchange account name.

3. add another mail account within this outlook profile by selecting manual => "pop or imap" and use these settings:

***Personal information deleted by the moderator. Please see the Microsoft Community Frequently Asked Questions for more information on how you can protect your privacy.***

4. set this new IMAP/SMTP account as default send/receive account, move it onto the top ad the left folder panel and just continure workung with this IMAP account only.

This doesn't look like a good workaround but just try it out: you'll see it will work as expected:

- correct sender addres without any "in behalf of"

- also the sent items are syncing correctly

- you can still work with the calender and contacts via the office 365 acccount as usual

btw: Thanks a lot to the Microsoft Answer Desk Agent who showed me this workaround during a LogMeIn-Remotesession :-)

This was a really awesome support experience!

Good Luck!

Gue

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I'm afraid this doesn't work for me, IMAP never has. My emails still have the Sender header that displays "on behalf of...". Responses to calendar invitations are sent by default from the dodgy Exchange account address (fair enough, that owns the calendar) and if changed to the IMAP account they still get the Sender: header.

But maybe something has changed as now I have an improved Outlook desktop setup fairly simply, on EAS, after resetting it yesterday.

My primary/login email is a non-outlook address on my own domain. I use a personal email address @ my.domain which is different to the primary alias (for privacy/security), this is set up in outlook.com as a POP/SMTP external connection (not IMAP, as that fails to keep copies of sent emails). It is also set as the default sending email address. (You didn't mention how you get emails into Outlook.com addressed to you @ yourdomain.com).

In the manual EAS setup, I gave my personal email address as the address, and the primary alias as the username, on server eas.outlook.com. And that was it. I can now send emails from my preferred address, and respond to invitations correctly with it as well. I've tried and failed with many permutations before, this may be the first time I have had all these settings lined up together.

Unfortunately it is not working from my Windows 10 phone using Outlook Mail, where invitation responses go from the primary alias (not my real email) with a Sender: header every way I've tried. Maybe some day...

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hello,

If in any case you are still encountering the same issue, we suggest that you get in touch with our Answer Desk department to further assist and resolve your case. Check this link.

Thank you.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

IN,

You will need to create a CNAME record at your domain registrar in order to add your account to Outlook using a custom domain.  See the fourth Known Issue in this topic, https://support.office.com/en-us/article/Reconnect-Outlook-2016-or-Outlook-2013-to-Outlook-com-for-uninterrupted-email-access-cda1751d-9503-40bf-bf76-e79454ac5eb3?ui=en-US&rs=en-US&ad=US.

If you are somehow getting EAS to work as a workaround for now it won't work for very long.  The Outlook Team is currently in the process of blocking EAS. 

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi,

Thanks for responding.

I encountered the error when i was forced onto the new outlook.com platform.  That was on January 30, 2017.

My personal (non-outlook.com) account is set as the primary alias for my Microsoft account.

I had not made any changes to my settings on the PC.

Thanks,

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated March 6, 2021 Views 8,628 Applies to: