Web links in Outlook 2010 mail won't launch. Fixes recommended so far don't solve this problem

I am running Outlook 2010 in Windows 7. I see that several people are having problems getting web links in email so launch. So am I. I get a message that says "Windows can't open this file:" I think this must be an Outlook problem - all this used to work fine. I don't have anyother browser on the machine and if I go to my web mail (Yahoo) and click links there then then launch fine in IE 9. I have tried the several fixes listed but none seem to fix this problem. Links all worked fine a week ago. Any ideas?
 

Question Info


Last updated July 17, 2019 Views 24,433 Applies to:
Answer
Answer

Is this a standalone version of Outlook 2010 or is it part of the Office 2010 suite?

 

Go to Start > Default Programs > Associate a file type or protocol with a specific program > scroll down to Protocols > Select HTTP > click Change program > Select Internet Explorer.

 

Go to Start > Default Programs > Set program access and computer defaults > click Custom > select Internet Explorer.

Note: The above steps have to be done even if Internet Explorer is set as the default program.

 

If you still face the same issue, you may run the Fixit tool (method 2) provided in the link below to completely remove Office 2010 from the computer. Once it’s done, restart the computer, then reinstall Office 2010 and see if the hyperlinks open fine in Outlook.

http://support.microsoft.com/kb/290301

Note: Save the Fixit program onto the desktop and then run the Fixit from the desktop.

22 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.