how to copy a list of email contacts and paste them only as names (not names + email address)

In Outlook 2007 when I copied a list of email addresses from the "To" field in an email and then pasted it in the email body, it would paste only a list of names, without email addresses.

But in Outlook 2010, there seems to be no way to replicate that functionality. Now, the paste option pastes the list as name along with email address like:

Tom Smith <*** Email address is removed for privacy ***>; Albert Shaw <*** Email address is removed for privacy ***>

How can I paste so that I see only: Tom Smith; Albert Shaw

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

You are copying from the message's To field?

What do you see in the body if you hit Reply or Forward?

ie, in the header block:

From: name [mailto:address]
Sent: Wednesday, August 25, 2010 6:15 PM
To: Diane; Can; Andrew
Subject: RE: now that you are back



Diane Poremsky [MVP - Outlook]
Outlook Tips http://www.outlook-tips.net/
Outlook & Exchange Solutions Center http://www.slipstick.com
Subscribe to Exchange Messaging Outlook weekly newsletter or Outlook Daily Tips
Diane Poremsky [Outlook MVP]
Outlook Resources: https://www.slipstick.com
https://www.outlook-tips.net


** I don't work for Microsoft, I just volunteer here.**

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

You are copying from the message's To field?

What do you see in the body if you hit Reply or Forward?

ie, in the header block:

From:name [mailto:address]
Sent: Wednesday, August 25, 2010 6:15 PM
To: Diane; Can; Andrew
Subject: RE: now that you are back



Diane Poremsky [MVP - Outlook]
Outlook Tips http://www.outlook-tips.net/
Outlook & Exchange Solutions Center http://www.slipstick.com
Subscribe to Exchange Messaging Outlook weekly newsletter or Outlook Daily Tips

Yes, I am copying from the To field. My specific use case is I send an email to a certain group of people, and I put their names within the body saying "the following people were requesting such-and-such". So I enter everyone's names in the To field and earlier I was able to copy the entire list from the To field and paste it in the body and it was pasting only the names.

With Outlook 2010, it is pasting name <email>; name <email>

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

If you click on ‘To field’ it will select the name and email address. Try to double click on the address in ‘to’ field and copy only the name and then paste it in the new message window.

 


Ganesh Kumar N

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

If you click on ‘To field’ it will select the name and email address. Try to double click on the address in ‘to’ field and copy only the name and then paste it in the new message window.

 


Ganesh Kumar N


But I have several names in the To field. If I have to manually get the names, it will be too time-consuming. Why isn't there a Paste Special-type of functionality to paste name only or paste name+email?

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I would like a solution to this annoying problem as well.  I've looked all over and cannot find a setting to change this behavior.  It seems to just take the name when pasting between e-mail recipient fields but in anything else includes the smtp address in carets as well.   It would appear outlook is copying the name as a multivalued string instead of a single value that you see on the string and includes the hidden smtp information for use in addressing new emails.  Any help would be appreciated.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I too have this problem, It would be great if Microsoft could provide an answer to this problem.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

In Outlook 2010, copying from the To field should include the display name and email address. In older versions, you need to get the display names/addresses from the message header.

See http://www.slipstick.com/tutorials/create/dl.asp - use the first section to get the display name and addresses - or use this method to get the names and not the addresses.



Diane Poremsky [MVP - Outlook]
Outlook Tips http://www.outlook-tips.net/
Outlook & Exchange Solutions Center http://www.slipstick.com
Subscribe to Exchange Messaging Outlook weekly newsletter or Outlook Daily Tips
Diane Poremsky [Outlook MVP]
Outlook Resources: https://www.slipstick.com
https://www.outlook-tips.net


** I don't work for Microsoft, I just volunteer here.**

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Yes, I am copying from the To field. My specific use case is I send an email to a certain group of people, and I put their names within the body saying "the following people were requesting such-and-such". So I enter everyone's names in the To field and earlier I was able to copy the entire list from the To field and paste it in the body and it was pasting only the names.

With Outlook 2010, it is pasting name <email>; name <email>


Hit Forward or Reply  - you'll have a block like this in the body - copy and paste the names where ever you want:

Sent: Thursday, September 16, 2010 9:42 PM
To: Tony; Angela; Heather; Mary Mitchell; Janet (home); Frank & Jeni; Diane Poremsky;
Subject: New Address




Diane Poremsky [MVP - Outlook]
Outlook Tips http://www.outlook-tips.net/
Outlook & Exchange Solutions Center http://www.slipstick.com
Subscribe to Exchange Messaging Outlook weekly newsletter or Outlook Daily Tips
Diane Poremsky [Outlook MVP]
Outlook Resources: https://www.slipstick.com
https://www.outlook-tips.net


** I don't work for Microsoft, I just volunteer here.**

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thank you for the reply Diane, however it would seem to me that this is only a work around to a larger problem eg: 2010 Design change by Microsoft affecting user behavior.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi,

It is an annoying feature isn't it? My work around is this:

  1. In the email window, click the To: button. The Select Names Global Address List dialog box opens.
  2. Add all of the people you want to any of the fields.
  3. Before clicking OK, copy the names from the desired field.

By copying the names from the To: field in the Select Names window, I am able to get just the names...no addresses...when I paste in the body of the email.

Hope it helps,

C.

43 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated February 22, 2021 Views 26,741 Applies to: