Remote Desktop Connection keyboard language

I'm on a macbook pro (my 3rd through the years) and I've had this problem for as long as I can remember:

My mac keyboard is set to spanish, my Win7 and Windows Server 2008 computers also have their keyboards set as spanish. However when I connect with RDC to any of the windows computers the session has an english keyboard layout.

I've found many threads about this but no one has a workaround. Does anyone have a clue as to why this happens? 

Also, I can't find forums for RDC and Messenger so I am posting here, hope it's the right place.






Thanks in advance.
---------------------------
System specs: Lion 10.7.1, RDC 2.1.1, Clients: Win7 / Win2008R2
 

Question Info


Last updated November 15, 2018 Views 65,438 Applies to:
Answer
From the thread I linked to:

If you want the session to use the default keyboard layout stored in the user profile instead of the layout provided by the Terminal Server client after the user logs on to the Terminal Server computer, you can set the IgnoreRemoteKeyboardLayout registry value to 1. After users first connect to the Terminal Server computer, configure the default keyboard layout and input language that you want, and then log off. All later user logons will use the default keyboard layout and input language from the profile.

 

To do so, please perform the following steps: 

 

1.            On the terminal server, click Start, click Run, type regedit, and then click OK.

 

2.            Locate and then click the following registry subkey:

 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout

 

3.            On the Edit menu, click Add Value, and then add the following registry information:

 

Value name: IgnoreRemoteKeyboardLayout

Data type: REG_DWORD

Value data: 1

 

4. Quit Registry Editor.

 

After you first connect to the Terminal Server computer, configure the default keyboard layout and input language that you want, and then log off. All later user logons will use the default keyboard layout and input language from the profile.


47 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.