Microsoft Teams - Installer for Mac Error

Trying to install the Microsoft Teams application on Mac OSX 10.12.3 and I receive an error "A JavaScript error occured in the main process" The only option is to click OK.

I've removed the app, cleared the trash, rebooted, re-downloaded and tried this multiple times but I receive the same error message each time.

Answer
Answer

Issue is that the "/Users/jay/Library/Application Support/Microsoft" directory is owned by "root", which is why the 'Teams' folder can not been created when you start the application and it tries to create the directory using your login id (the id you've logged in your Mac).

You can check this by doing a "ls -lat" of the "/Users/jay/Library/Application Support" directory:

  drwxr-xr-x   3 root    staff   102 May 14 19:43 Microsoft

The solution is to change the ownership of the Microsoft directory to your login id, which is listed in the path after "/Users/", in your case "jay".

Steps: 

Open Terminal app and at the command prompt type the following commands ("jay:" and "root#:"  are the ends of the command prompt, you don't type them!) substituting "jay" in all paths below with your login id:

  jay: cd Library/Application\ Support

  jay: sudo su -

  Password: (type the password for "jay" here)

  root# cd /Users/jay/Library/Application\ Support

  root# chown jay Microsoft

  root# ls -lat | grep Microsoft

  drwxr-xr-x   4 jay  staff   136 May 26 17:23 Microsoft

The last output above shows the Microsoft directory is now owned by "jay".

Close Terminal app and start Teams.

97 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated October 29, 2020 Views 13,705 Applies to: