Unflip mouse buttons in Microsoft RDC client

I used to have an older version of the Microsoft RDC client with the mouse buttons reversed because I am left-handed. I flipped the left and right mouse buttons of the mouse in preferences, which made the right button behave as primary mouse button also in remote sessions.
I'm trying to get help for you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey David,

Your post is a little vague, but I'm assuming you want to revert back to the standard mouse controls.

I've got a hunch that this setting is stored in RDC's preferences file. Let's try removing them and see if that resets the mouse settings:
  1. With Finder open, choose Go > Go to Folder...
  2. Type in the following and press Go:

    ~/Library/Preferences

  3. Find and move the following files to the Trash:
  • com.microsoft.rdc.plist
  • com.microsoft.rdc.plist.lockfile
  • com.microsoft.rdc.LSSharedFileList.plist
  • com.microsoft.rdc.LSSharedFileList.plist.lockfile

Once the files are in the Trash, try opening RDC and see if the mouse works correctly.

Hope this helps!
Instead of telling our young people to plan ahead, we should tell them to plan to be surprised.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you for your reply. Unfortunately, my original post was cut off and only the first third of my question was posted. In the other two thirds, I went over what I tried, which included your suggestion.

I also tried these without luck:

*Uninstalled RDC (using a third party uninstaller), and did a complete file search for anything with "rdc" to clear all related caches
*I tried creating two accounts, ran RDC on one, did a full folder diff - but did not find anything new.
*Deleted ~/Library/Preferences/ByHost/.GlobalPreferences.[MACaddress].plist to reset all mouse/touchpad settings
*Ran lsof to get all open file handles when RDC runs to see if I missed anything

I am unable to reproduce the issue with other user accounts, no matter what combination of button-switching I try. I copied my entire Library/Preferences folder to a new account - still cannot reproduce.

Incidentally, the mouse is reversed regardless of what the primary assignment in the Mouse setting pref pane is.   That seems to be the issue - RDC respected the original change, but not the change back.

This issue has persisted through an OS upgrade and two time machine restores. At this point, the only solution seems to be to start over with a new user account - but I know that the setting is somewhere in my user folder, so I don't know what to leave out!



Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This issue has persisted through an OS upgrade and two time machine restores. At this point, the only solution seems to be to start over with a new user account - but I know that the setting is somewhere in my user folder, so I don't know what to leave out!

Well, the issue is that there simply aren't many RDC files in a profile. Here's are the only other places to look:

  • ~/Documents/RDC Connections/
  • ~/Library/Caches/Remote Desktop Connection

If removing the files there doesn't help resolve the issue, I'm not there's many other places to look.
Instead of telling our young people to plan ahead, we should tell them to plan to be surprised.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Have you tried connecting to your remote host and changing mouse buttons in the Windows Control Panel instead of on your Mac?

Also, have you tried changing the Secondary Mouse Button setting in RDC menu --> Preferences... --> Keyboard?

Hope this helps!
William M. Smith
http://talkingmoose.net
http://twitter.com/meck

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yes, this setting is on the Mac rather than on Windows.  As a sysadmin, I connect to many different computers, so I have to change the setting on each one before I can use them - and then change them back if I log on physically.  Sometimes I connect to multiple levels -> gateway RDP client -> desktop RDP and I have to change it at each level.

I've deleted the ~/Documents/RDC Connections/ folder, which deletes the connection profiles.

I also tried editing the plist XML to see if I could force a Primary Mouse Button setting, but it did not work.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated May 31, 2020 Views 2,149 Applies to: