Onedrive Shared With Me files disappear after one day

I have a spreadsheet in OneDrive that I have shared with another user (can edit).  At first,  it shows up in her "Shared With Me"  location for about a day.  The next day her  "Shared With  Me"  shows up empty.  

If I create a link to share,  it works fine so she is able to access the file. I have several files I need to share with several different users and they all have the same problem.   I really want the "Shared with me"  option to work so we aren't having to keep up with multiple links for multiple users.  


Hi Mandy,

We have strike out the information that I delivered earlier as it is not applicable to you after verifying the information you provided via PM. I will continue to work with you to troubleshoot this issue.

Please kindly let us know whether the document which your Office 365 global admin shared with you will still show up in your “Shared with me” view after one day. This will help us identify if it is either a scoping issue or an independent problem.

Meanwhile, could you try manually re-indexing your OneDrive for Business site by the steps below and re-sharing the file with your coworker to see if there is any improvement?

Here are the detailed steps:

1. Go to your OneDrive for Business library, click Gear in the right-upper corner > Site Settings.

2. Click Search and offline availability under Search section.

3. In the Reindex Site section, click Reindex Site.

4. When a warning appears, click Reindex Site again to confirm. The content will be re-indexed the next scheduled time.

5. After re-indexing your OneDrive for Business site, click the ellipses (...) for the affected file and then click Share.

6. Click Shared with in the left side menu and Advanced.

7. Delete the user’s permissions by clicking Delete unique permissions then re-share the file by the steps Linda provided above.

In addition, please also provide your OneDrive for Business URL to us so we can check from backend. I have sent you a private message to collect it. You can access it via the link below:



Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.


Question Info

Last updated August 8, 2020 Views 4,166 Applies to: