Site is not access by Extranet user (User not in directory)

Hi,

I am facing a problem that i have assigned a permission to Extranet user but he is not accessing the site whenever he try to access the site a below screen showing

When i am checking the the detail of user then it showing 

*** Email address is removed for privacy ***
Extranet User
*** Email address is removed for privacy ***

If anybody faced same issue please help me.

Thanks,

 

Question Info


Last updated February 19, 2020 Views 4,337 Applies to:
Answer
Answer

Hi Rjj,

As there are some similar threads indicate that the same error message will appear if the account the user sign in to the site with is not same as the one receives email invitation, we’d like to confirm if you are in the same situation.

Please refer to We're sorry, but ... can't be found in the ...sharepoint.com directory. Please try again later, while we try to automatically fix this for you and User not in directory.

If yes, please refer to the suggestion Ran provided in this thread:  We're sorry, but ... can't be found in the ...sharepoint.com directory. Please try again later, while we try to automatically fix this for you.

First, please go to the following location to check if the user’s account is listed there. If yes, please remove it from these locations, then assign permission to see if it works.

  • Remove the external user from the active users list in the portal.
  1. Go to Office 365 portal -> Users -> Active Users
  2. In the user list, find the external user account. It looks like *** Email address is removed for privacy ***
  3. Delete the user.

  • Remove the external user from the UserInfo list.
  1. Navigate to the site, edit the URL by adding the following string to the end of it:
    _layouts/15/people.aspx/membershipGroupId=0
    For example, the full URL will resemble the following:
    https://<contoso>.sharepoint.com/_layouts/15/people.aspx/membershipGroupId=0
  2. Select the user’s account from the list.
  3. Actions -> remove selected users from this SharePoint group.

  •  Remove the external user account from the site.
  1. Download and install the SharePoint Online Management Shell. For more information, go to the following Microsoft website:
    Introduction to the SharePoint Online Management Shell
  2. Run SharePoint Online Management Shell as administrator.
  3. Type the following cmdlet:
    $cred = Get-Credential
  4. In the Windows PowerShell Credential required dialog box, type your admin account and password, and then click OK.
  5. Connect to SharePoint Online, and then type the following cmdlet:
    Connect-SPOService -Url https://tenantname-admin.sharepoint.com -Credential $cred
  6. Remove the user from each site collection. Type the following cmdlet, and then press Enter:
    $ExtUser = Get-SPOExternalUser -filter *** Email address is removed for privacy ***
    Note: In this cmdlet, replace *** Email address is removed for privacy *** with the affected account. Then, to remove the user, type the following cmdlet, and then press Enter:
    Remove-SPOExternalUser -UniqueIDs @($ExtUser.UniqueId)

In addition, we can go to https://tenantname-admin.sharepoint.com/_layouts/15/online/ExternalSharing.aspx to select External users must accept sharing invitations using the same account that the invitations were sent to option to avoid same issue.

Regards,

Joanne

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.