Add additional smtp aliases to Office 365 Groups

Is it possible to add additional smtp aliases to an Office 365 group? I am finding conflicting information but it appears it is possible via Powershell by using

Set-UnifiedGroup -Identity "Office 365 Group Name" -EmailAddresses @{Add="smtp:emailaddress"}

When I did this I was able to use the new alias in addition to the primary for the Office 365 group internally but from external I get the following message despite having "-RequireSenderAuthenticationEnabled $false".

Here is what I get when trying to send to the new additional smtp alias from gmail

Message not delivered

Your message couldn't be delivered to emailaddress because the remote server is misconfigured. See technical details below for more information.

The response from the remote server was:

550 5.4.1 [emailaddress]: Recipient address rejected: Access denied [BY2NAM03FT058.eop-NAM03.prod.]

Final-Recipient: rfc822; emailaddress
Action: failed
Status: 5.4.1
Remote-MTA: dns; *.mail.(
 the server for the domain domain.)
Diagnostic-Code: smtp; 550 5.4.1 [emailaddress]: Recipient address rejected: Access denied [BY2NAM03FT058.eop-NAM03.prod.]
Last-Attempt-Date: Tue, 03 Oct 2017 14:48:36 -0700 (PDT)

Anyone have an idea why this would be or suggestions on what to try?

 

Question Info


Last updated September 25, 2019 Views 7,706 Applies to:
Answer
Answer

OK, so I believe I solved the problem (for me at least).

This might still be an effect that may change back, but I'll describe it nonetheless.

So, I noticed in powershell that the group's AccessType was Private and that got me thinking from Zhao's suggestion that you had to add outsiders in order to receive mail from them.

So I changed the group's AccessType to Public and tested sending to proxy addresses and it worked!

Then I changed it back and I initially assumed that it would still only work for the principal SMTP address, so I changed it to one of the proxy addresses. Still set as Private It worked receiving for a proxy address.

Here I sent another mail to the original principal, now just a proxy, and to my surprise, it still worked!

So, as far as I can tell, you should only need to change the group's AccessType to Public and back to Private and all the proxy addresses ought to work fine.

Of course, I'm assuming you have you group(s) set the same way I do, as Private.

If that is not the case, at least try to change it and then change it back.

I hope it helps!

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.