Error 403 when I upload PST file with AzCopy

Hi, everyone!

What i'm trying to do is use the "data migration" option in office 365 to upload a PST file using azure azopy.

I tried to follow the instructions:

https://support.office.com/en-us/article/use-network-upload-to-import-your-organization-s-pst-files-to-office-365-103f940c-0468-4e1a-b527-cc8ad13a5ea6#ID0EABAAA=Instructions

Everything works but when i'm at step 2 I start to run into problems.

While using the Azure Azcopy i use the following command:

AzCopy.exe /Source:\XERSES\pst /Dest:"SAS-URL" /V:C:\Users\username\Desktop\uploadlog1.log /S

However it results in the transfer being failed. The logfile gives the following:

[2018-03-15 15:03:36.228+01:00] >>>>>>>>>>>>>>>> [2018-03-15 15:03:36.228+01:00][VERBOSE] 7.1.0 : AzCopy /Source:\\XERSES\pst /Dest:SAS-URL /V:C:\Users\username\Desktop\uploadlog11.log /S [2018-03-15 15:03:36.290+01:00][VERBOSE] Attempt to parse address '\\XERSES\pst' to a directory as a candidate location succeeded. [2018-03-15 15:03:36.300+01:00][VERBOSE] Source is interpreted as a Local directory: \\XERSES\pst\. [2018-03-15 15:03:36.317+01:00][VERBOSE] Attempt to parse address 'SAS-URL' to a directory as a candidate location succeeded. [2018-03-15 15:03:36.317+01:00][VERBOSE] Destination is interpreted as a Cloud blob directory: https://****.blob.core.windows.net/ingestiondata. [2018-03-15 15:03:37.301+01:00][VERBOSE] Start transfer: \\XERSES\pst\backup1.pst => https://****.blob.core.windows.net/ingestiondata/backup1.pst [2018-03-15 15:03:37.588+01:00][VERBOSE] Transfer FAILED: \\XERSES\pst\backup1.pst => https://****.blob.core.windows.net/ingestiondata/backup1.pst. [2018-03-15 15:03:37.604+01:00][ERROR] \\XERSES\pst\backup1.pst: The transfer failed. The remote server returned an error: (403) Forbidden. HttpStatusMessage:This request is not authorized to perform this operation using this permission. RequestId:f3e03920-801e-0108-5766-bc9c95000000 Time:Thu, 15 Mar 2018 14:03:53 GMT [2018-03-15 15:03:37.604+01:00] Transfer summary: ----------------- Total files transferred: 1 Transfer successfully: 0 Transfer skipped: 0 Transfer failed: 1 Elapsed time: 00.00:00:01

I tried using a different way i found in this video using the "Miscorsoft Azure storage Explorer" and this also results in an error when im uploading the pst file.

https://www.youtube.com/watch?v=mTACJXdATvo

Hopefully someone can tell me what i'm doing wrong and how to correct my problem. 

My apologies in advance if my question is a stupid one :D

 

Question Info


Last updated August 14, 2018 Views 1,604 Applies to:

Hi Stephan,

 

Please use

AzCopy.exe /Source:<Location of PST files> /Dest:<SAS URL> /V:<Log file location> /Y  to give it a shot, not /S

 

Regards,

Hans


10 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Stephan,

Is there any update?

Thanks,

Iry

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Specifying the /Y helped at my similar case.

It doesn't make sense to me, what it does. But it worked. :)

/Y

Suppresses all AzCopy confirmation prompts. This option also allows the use of write-only SAS tokens for data upload scenarios, when /XO and /XN are not specified.

Applicable to: Blobs, Files, Tables

14 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.