Staged Migration - *** Email address is removed for privacy *** disappeared


We are finishing up a staged migration from Exchange 2003. All regular users have been migrated, but we are cleaning up a few shared mailboxes before the MX records can be updated to the Office 365 settings. We are using directory sync with and AD FS server.

The issue is that on one user (my user, which happens to be the one that setup Office 365, not sure if that's relevant) lost the *** Email address is removed for privacy *** proxyaddress in the cloud. Without that address, all external email gets bounced. From what I can tell, this shouldn't be possible in a dirsync setup. I'm not aware of any config changes. I have confirmed that the targetaddress attribute on premise did not change.

Can that address be added back? How was it removed?

The temporary solution I have for now was to create a new cloud user, update the target address to the new user, then create a mailflow rule to redirect email to my original synced user. This is not ideal because it is using 2 licenses for 1 user.

I have already tried adding a new proxy addresses on premise, but it seems addresses aren't synced. I also tried adding a new address on the web portal and through powershell, but no luck with directory sync enabled.


Question Info

Last updated March 24, 2018 Views 277 Applies to:

Hi BarneyD,

You’re correct. The smtp email address with the tenant domain is not synced by Directory Synchronization. If this address is missing due to some unexpected factors, I suggest you use the following steps to add it back:

1. Temporarily disable/deactivate Directory Synchronization on the Office 365 admin portal. So that we can edit users in Office 365.

2. In Exchange Admin Center, manually add this address back.

3. Activate Directory Synchronization again.

If the issue persists, please connect PowerShell to Exchange Online, and then run Get-Mailbox UserName | fl to check the email addresses. To protect your privacy, I have sent a private message to request the information. Please use this link to access the private message:



Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.