ADFS page launches popup in Internet Explorer

We are running ADFS 3.0 on Win2012 R2. When using Chrome, Office 365 redirects to a "regular" ADFS login page. However when using Internet Explorer a login popup windows shows up. I tried from 3 different clients and they all have the same problem. Any idea why? Thanks!

Answer
Answer

Hi Christos,

By default, the internal user will use the Integrated Windows authentication (IWA) when sign into Office 365 using IE. If you add the related office 365 sites in the intranet settings, the user will sign into Office 365 seamlessly, that’s exactly how ADFS/SSO should work in the internal network.

For other browsers and external network, it will use Forms-based authentication (FBA), which the user will be redirected to an organization sign in page (as you can see in Chrome). In ADFS 3.0, you can also change the authentication type in Chrome to IWA so that the user can sign into Office 365 without prompting. Or if you want all the users to use the FBA, you can change the settings in the ADFS server so that every user will be redirected to the organization sign in page, however, since it’s a setting related to the ADFS server which our forum doesn’t focus on, if you would like to perform the changes, it’s recommended that you post a new thread with details in our Directory Service Forum via: https://social.technet.microsoft.com/Forums/en-us/home?forum=winserverDS&filter=alltypes&sort=lastpostdesc, your understanding is appreciated.  

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated April 30, 2020 Views 9,208 Applies to: