Unable to restart the Microsoft Software Protection Platform service from command line - Win81 MS Office 2013 SP1

I'm unable to restart the Microsoft Software Protection Platform service on a Windows 8.1 laptop for MS Office 2013 SP1 (32-bit) using the following command:

cscript ospp.vbs /osppsvcrestart (issued from C:\Program Files (x86)\Microsoft Office\Office15)

When this is run, a window appears with the title ospp.vbs and the text "Error: The Software Protection Platform service is not installed"

I verified that the service is installed in services.msc, and was able to manually stop and restart the SPP service in the Services console without issue.

The command runs correctly when restarting the MS Office 2013 SPP on Windows 7 devices.

Has anyone else seen this or have a solution for it?

 

Question Info


Last updated October 15, 2018 Views 5,483 Applies to:
Just for fun I performed an Office Repair.  This did not fix the issue.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello,

Welcome to Microsoft Community and thank you for posting your query.

Let me assist you with Office issue.

Since repairing the Office application did not resolve the issue, let’s uninstall Office 2013 using the ‘fix it’ tool from the following article which will remove all the installed components of Office 365/Office 2013 from the computer.

http://support.microsoft.com/kb/2739501

Once the uninstallation is completed you may use the installation source file and the product key to reinstall Office 2013 on the computer and verify the status.

I hope the above information helps. Let us know if you need further assistance.

Thank you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello,

Welcome to Microsoft Community and thank you for posting your query.

Let me assist you with Office issue.

Since repairing the Office application did not resolve the issue, let’s uninstall Office 2013 using the ‘fix it’ tool from the following article which will remove all the installed components of Office 365/Office 2013 from the computer.

http://support.microsoft.com/kb/2739501

Once the uninstallation is completed you may use the installation source file and the product key to reinstall Office 2013 on the computer and verify the status.

I hope the above information helps. Let us know if you need further assistance.

Thank you.

Thank you for the information.

Using the above link, the Fix It tool was run, and the software was reinstalled after a reboot.  The software was successfully activated.  When the command was run, it produced the same exact error.  Are there any other steps that I should try?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

To further troubleshoot this, Office was again uninstalled with the Fix It tool (which, incidentally, also uninstalled Lync 2013...). 

Lync 2013 was installed after a reboot, the command was issued, and the same error message appeared. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Microsoft Software Protection Platform service is an activation .exe which would be working at the background.

After installing Office on the computer you were able to activate Office it means it is now working fine at the background. You can just leave it and relax now.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Microsoft Software Protection Platform service is an activation .exe which would be working at the background.

After installing Office on the computer you were able to activate Office it means it is now working fine at the background. You can just leave it and relax now.

Thank you for your response.

The reason that I am attempting to restart the service from the command line is because this command is part of a script to change the KMS server IP Address used by OSPP prior to software activation. 

The only other options that I have at this time is to ask the users to reboot, or manually force a reboot.  This is both time consuming and disruptive to the users.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Has anyone had this issue with Windows 7?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello,

Thank you for your reply.

 

Since you need help to change the KMS server IP address used by OSPP for better suggestion, you may post your query in Office IT pro using the following link.

http://social.technet.microsoft.com/Forums/en-US/officeitpro/threads

 

Thank you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello,

Thank you for your reply.

Since you need help to change the KMS server IP address used by OSPP for better suggestion, you may post your query in Office IT pro using the following link.

http://social.technet.microsoft.com/Forums/en-US/officeitpro/threads

Thank you.

Thank you for pointing me in this direction.

The thread will continue at https://social.technet.microsoft.com/Forums/office/en-US/fd2c668a-c4dc-4e6f-b793-94858df7ccc1/unable-to-restart-the-microsoft-software-protection-platform-service-from-command-line-win81-ms?forum=officesetupdeploy

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.