Microsoft Office 2016 encountered an error during Setup

I have tried to install the Office on Windows 10 Home but unable to complete it. almost nearly at the end the installation process rolls back and an error message "Microsoft Office 2016 Professional encounter an error during setup" appears. I have read the thread on this same issue and have tried everything suggested there but to no avail. I had a working office on this same machine previously but due to some reasons I had to recover my windows to it's factory defaults. After that I am unable to install the office at all. Any help guys, i am attaching the screenshot of the error.

here is the log file

Setup 2016 Log File.txt

 

Question Info


Last updated August 20, 2019 Views 79,455 Applies to:
Answer
Answer

I have found a solution to the problem and it calls for you to go into the scheduled task and delete the Office folder in that and then try to install Office. Try this...

 

  • I know this is a necro post but I wanted to add to the solution list for anyone else who continues to have this problem, even now in 2016.

I was having this same issue and tried every solution on this post without success.  It should be noted, my issue started after I attempted to unininstall a component of my existing Office 2013 installation.  Instead of launching the "change" dialog of the MS Office Setup, the system registered that event as a flat uninstall of Office Pro 2013.  From that point forward I was unable to reinstall Office 2013 Pro.  I had other Office 2013 apps installed (Visio and Project) so I even removed those hoping that would fix it but setup continued to fail.

At any rate, I ended up finding the solution myself, however I do not fully understand why it was an issue to begin with.  At any rate...

I first properly enabled verbose logging by following instructions found here (since the instructions contained within this post seemed to miss a few steps):  https://blogs.technet.microsoft.com/odsupport/2010/12/30/troubleshooting-office-installation-failures/

While looking at the logs I found my issue stemmed from the following command trying to be run:  

MSI(INFO): 'CAQuietExec:  Entering CAQuietExec in C:\WINDOWS\Installer\MSIEA18.tmp, version 3.6.3025.0'

MSI(INFO): 'CAQuietExec:  "schtasks.exe" /create /f /tn "Microsoft\Office\OfficeTelemetryAgentLogOn" /xml "C:\Program Files\Microsoft Office\Office15\1033\officeinventoryagentlogon.xml"'

MSI(INFO): 'CAQuietExec:  ERROR: The system cannot find the path specified.'

MSI(INFO): 'CAQuietExec:  '

MSI(INFO): 'CAQuietExec:  Error 0x80070001: Command line returned an error.'

MSI(INFO): 'CAQuietExec:  Error 0x80070001: CAQuietExec Failed'

It was erroring trying to register a scheduled task but was complaining that the system could not find the path specified.  After tracking with procmon I verified the XML file used for this command was actually being created.  I then focused on the other path mentioned in that error:  "Microsoft\Office\OfficeTelemetryAgentLogOn".

This is the path the scheduled task would actually live at so I opened Task Scheduler and drilled down through the path.  I found my path ended at "Microsoft\Office" and there were 0 tasks here.  

Since this path was empty, I deleted the Office folder entirely from Task Scheduler and re-ran setup again.  This time it finished successfully!

I don't know why the simple fact that the Office folder existed within Task Scheduler prevented this from running but its removal fixed my issue.

1283 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.