• July 17, 2017
    Announcement: New site design for Microsoft Community

    In July, Microsoft will roll out the first of ongoing site improvements aimed to modernize Microsoft Community and help customers get the most out of their community experience.

    • During the roll out period, you may see the old or new site design depending on your location

    • We expect the roll out to finish by 31 July

    Note: Past private message conversations will not move to the new site design. Please save any private messages you would like to keep.

     Learn more about the upcoming site improvements in this thread.

    Thank you for being part of Microsoft Community!

 
Question
10028 views

Cannot install Office 2010 -- error occurred while processing OSPPWMI.MOF

jppowers asked on

I am trying to update my daughter's Vista computer from Office 2003 to Office 2010. I purchased and downloaded the Microsoft Office Professional Academic 2010 installer from DigitalRiver. Her computer is running Vista on a Dell Latitude E6400.

The installer chugs along for a while and even finishes up, then rolls back all the installed files and finishes with a very non-descript error message "Microsoft Office Professional 2010 encountered an error during setup". I turned on full logging and excerpted the message below.

I've tried lots of advice; turned off antivirus; renamed \ProgramData\Microsoft Help; uninstalled 2003; reinstalled 2003 and chose Upgrade in the 2010 installer.

 

 

CAQuietExec:  "C:\Windows\system32\WBEM\mofcomp.exe" "C:\Program Files\Common Files\Microsoft Shared\OfficeSoftwareProtectionPlatform\OSPPWMI.MOF"
CAQuietExec:  Microsoft (R) MOF Compiler Version 6.0.6000.16386
CAQuietExec:  Copyright (c) Microsoft Corp. 1997-2006. All rights reserved.
CAQuietExec:  Parsing MOF file: C:\Program Files\Common Files\Microsoft Shared\OfficeSoftwareProtectionPlatform\OSPPWMI.MOF
CAQuietExec:  MOF file has been successfully parsed
CAQuietExec:  Storing data in the repository...
CAQuietExec:  An error occurred while processing item 2 defined on lines 12 - 20 in file C:\Program Files\Common Files\Microsoft Shared\OfficeSoftwareProtectionPlatform\OSPPWMI.MOF:
CAQuietExec:  Compiler returned error 0x8007054fError Number: 0x8007054f, Facility: Win32
CAQuietExec:  Description: An internal error occurred.
CAQuietExec: 
CAQuietExec:  Error 0x80070003: Command line returned an error.
CAQuietExec:  Error 0x80070003: CAQuietExec Failed

11 people had this question

Abuse history


The answered status icon Answer
Groverboy replied on

I had the same problem, but what solved it was, no kidding , installing Windows Search 4.0 first. You can find it here:

http://www.microsoft.com/windows/products/winfamily/desktopsearch/choose/windowssearch4.mspx?tab=Install%20It

 

There must be a component in Windows Search 4.0 that Office 2010 needs to install, at least on some systems, because I had tried everything , including the FixIt tools, but wasn't able to install successfully until I had installed Windows Search 4.0.

 

Be the first person to mark this helpful

Abuse history


progress