Microsoft Office is downloading the required feature? And will not Stop!

Yesterday night, I opened Word and a message popped up saying to update... something about english... I am sorry I can't exactly remember what it said.  I clicked ok.  When I tried using word, it was very slow and sometimes not responding.  A pop up at the bottom right of my screen came up (with the Office Logo in the bar next to the clock) saying that Microsoft Office is downloading the required feature... Microsoft office may appear unresponsive temporarily as the required files are downloaded. 

Well... this was last night, I had my computer open for maybe an hour or two after this.  When I turned my computer on this morning and used word, the same pop up returned.  When I click on the pop up or the office icon, it immediately disappears and does nothing.  And there is no way to access how far along the download has gotten.  Does anyone know what this is or how I can stop it?  I am worried that it may have been a virus or something.

Answer
Answer
SOLUTION:

Let it download the "required feature" but only after you have restarted your computer. It takes about 5-7 minutes for it to process once you click on the application (Microsoft Word Starter 2010) and about 10-15 minutes for it to download the "required feature."

The Microsoft Word/Excel Starter 2010 applications were pre-installed on my 2010 HP desktop PC.

Back in July (of 2011), I had to download a free trial of the full Home and Student version because I had to do a PowerPoint project.

It's now September, and when I opened Word Starter, it said that the trial for the Home and Student version had expired. I'm guessing that the trial version became the default opener for all my Word documents, and I only noticed it until recently because of the expiration message.

So, I decided to uninstall it (I made sure that it was the trial version by looking at the date it was created so that I didn't accidentally delete my pre-installed Starter version).

Well, when I tried to open up Word documents, it wouldn't allow me to. The reason was because those documents were set to open on the default application, which was the Microsoft Office Home and Student version - the trial application that I had deleted.

Now, I wanted to set the files to open up in Word Starter, but there was no way to set up the program as the default opener. Simply right-clicking a Word document and choosing "Open with..." did not work, because the Starter version doesn't seem to be a "real" application. It's a Click-to-Run application, and I couldn't choose it as the default program.

So, I read other threads on this forum that tried to offer solutions to this set-to-default problem. Most had said that I had to "repair" the program. I did that.

I then tried opening a Word document, but then it froze up as soon as I clicked anywhere on the page.
Then, this message would pop up in the lower right portion of the screen: "Microsoft Office is downloading the required feature...[something about not responding as it's updating...blah blah]."
It kept saying that, but there was a flagged problem (indicated by the white flag on Windows 7 OS's). The problem stated that Microsoft Office needed to download an update, but there was no specific update for it even when I manually tried checking for Windows Updates (Start > All Programs > Windows Update).

I was getting really frustrated.

So, I shut down my PC, and turned it back on.

I opened up Microsoft Word Starter 2010, and it had to process for about 5-7 minutes. I thought something was wrong with it but figured to let it continue "processing" just in case it was actually trying to do something.

When it finally finished processing, a blank document page opened up, but as soon as I clicked anywhere on the page, the message popped up again: "Microsoft Office is downloading the required feature...," but there was no problem about the update this time (the white flag did not indicate a problem). Therefore, it really must have started updating the "required feature" after restarting the PC and running the application.

As I was searching for the solution on this thread, it finished downloading the "required feature" and works perfectly fine, now.

I still don't know how to set Word Starter as the default opener for Word documents ever since I deleted the trial version, but at least it's up and running just fine.
...and I still don't know what the "required feature" was or how to check the progress of the download.

Again, the solution is as follows:
  1. Restart (or completely shut down and then turn back on) your computer.
  2. Click Microsoft Word Starter 2010 and let it complete its processing.
  3. Let it finish downloading the "required feature."
  4. Hopefully, this works for all of you.
Working hard and prioritizing means less stress and no worries.

4 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated June 23, 2020 Views 48,693 Applies to: