Stop Excel Constantly Checking Printer

Our office has recently upgraded to Office 2013. One major problem is the fact that Excel repeatedly tries to connect to the default printer, even for something as basic as changing font color in a cell. All printers are network printers, so this can cause significant delays, especially during high traffic periods.

-

We're losing a LOT of time each day to sitting here waiting for Excel to connect to the printer, when we're not even trying to print!

-

Changing the default printer to a PDF generator reduces the lag, but this isn't a good solution to the problem - I'm constantly working in multiple programs, and often need to print from other programs in the midst of working on a complex spreadsheet. If I've changed the default printer to PDF to make Excel usable, I have to change the printer selection for everything else I do.

-

So the question is, how do I stop Excel constantly checking with the printer?

 

Question Info


Last updated October 11, 2019 Views 7,516 Applies to:

I think if you use Normal view rather than Page Layout or Page Break Preview then Excel will not need to communicate with the printer.

You may also need to switch off File > Options >Advanced > Display Options for this worksheet: Show Page Breaks.

Microsoft Excel MVP, Oxford, England. www.manville.org.uk

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Normal view is the view I always work in.  The "show page breaks" option is unchecked.  I've searched through all the options looking for anything that might be relevant - have found nothing that makes any difference.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

In that case I'm out of ideas too.

It's not something I have observed myself.

One thing to try would be whether it occurs in Safe mode (holding down Ctrl while launching Excel).

If it doesn't then some add-in or startup program is having an effect on the behaviour.

Microsoft Excel MVP, Oxford, England. www.manville.org.uk

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks, Bill - yes, it occurs in safe mode, too.

This appears to be a "feature" some smart programmer added without understanding the consequences.  Having a program check to make sure your printer can print what you're creating sounds like a great idea, but for those of us working on congested networks, or for those who connect a laptop to a network printer at work but not at home, there ought to be a way to disable the behavior.

Maybe we'll just have to go back to 2003, or beyond.

(Or switch to Open Office?  No such issue with their software.)

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am wondering if it might be related to a problem that was revealed about a process named splwow64.exe - basically it is supposed to be active until a short time after a print job has finished, but there were issues with it hanging and eating lots of CPU cycles.  See this discussion for more detail:

http://answers.microsoft.com/en-us/office/forum/office_2010-excel/excel-2010-problem-whenever-print-area-is-set/f8d2c9c3-fc97-435c-8288-86d9c81e585d

While your issue doesn't sound exactly the same, it does sound like it might be related.

There was a patch for this problem published if you are using 64-bit Windows 7 with Service Pack 1 (SP1) installed (or are using Windows Server 2008 R2 [R2 = 64-bit]).  That patch is here:

http://support.microsoft.com/kb/2815716

I am free because I know that I alone am morally responsible for everything I do. R.A. Heinlein

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for the suggestion, JLLatham.  I am running 64-bit Windows 7 (SP1). But...

  • No print area has been set on most of my spreadsheets.
  • CPU usage is 0% - 1% when this lag is occurring.
  • splwow64.exe isn't among the processes running.
  • Early in the morning, when few users are working, the lag is only a moment. Once others arrive, and network traffic increases, the delay increases accordingly.

I've found mention of this issue elsewhere going back to Office2007...

http://superuser.com/questions/32457/how-can-i-prevent-word-excel-from-trying-to-reach-the-printer

https://cybertext.wordpress.com/2011/04/21/word-very-slow-to-load-and-respond-solved/

http://smallbusiness.chron.com/slow-startup-accessing-printer-microsoft-office-2010-72278.html

 

but the only "solutions" I see involve changing the default printer. As I noted in the original post, this is not a good option for me.  I love this one:

"If your computer accesses the printer via the network, Office may hang for a few seconds or stop loading completely if the network is inaccessible. Microsoft recommends connecting the printer directly to your computer if this problem persists..." (from the third link above)

As though that would be an option in an office environment where many users share a printer!

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I understand it is difficult on the work environment, since this is the only work around which shows that it could fix the problem so you can give a try to check that sorts out.

If you can’t do that then you can check with your IT team if they have any other work around.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.