EXCEL slow loading in Windows 10

After upgrading to Windows 10 on my Surface Pro 3,  I have Office 365 installed.  If I click on an Excel file it takes 8-10 seconds before the Excel banner even appears.  It doesn't matter how small the Excel file is, I get the same results.  Word loads normally, even with large files.  Anyone else experiencing this?

Humm, just noticed another anomaly.  If I first open Excel it opens instantly.  If I then select the Excel file in Recent files it will load instantly also.  So the slow loading only occurs if I double click the Excel file directly.  Strange...

UPDATE:  Answer found!!  It happens when you have Hey Cortana turned on.  Turn Hey Cortana off, reboot and Excel files will load normal.  Very fast.   Surprised MS hasn't seen this and fixed it.  Found the answer on the internet.

 

Question Info


Last updated January 6, 2020 Views 28,830 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I purchased a new Surface Pro 4 and after upgrading to the Threshold 2, build 10586 now Excel works normal with Hey Cortana enabled. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

After upgrading to Windows 10 on my Surface Pro 3,  I have Office 365 installed.  If I click on an Excel file it takes 8-10 seconds before the Excel banner even appears.  It doesn't matter how small the Excel file is, I get the same results.  Word loads normally, even with large files.  Anyone else experiencing this?

Humm, just noticed another anomaly.  If I first open Excel it opens instantly.  If I then select the Excel file in Recent files it will load instantly also.  So the slow loading only occurs if I double click the Excel file directly.  Strange...

UPDATE:  Answer found!!  It happens when you have Hey Cortana turned on.  Turn Hey Cortana off, reboot and Excel files will load normal.  Very fast.   Surprised MS hasn't seen this and fixed it.  Found the answer on the internet.

I have the same issue with my surface pro. I do not have Hey Cortana turned on and the issue persists. As you say if Excel is already open the problem goes away, but this is not a very practical solution to my workflow.

Suggest Microsoft need to fix the issue.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello Matthew,

Are you getting any error message when you launch Excel? If yes, kindly specify. In the meantime, we would suggest you to do an online repair of your Office applications. To do so, you may follow the steps provided on this link.  

Let us know how it goes.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I do not have Cortana installed

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I had the same problem, excel could take a minute to load a spreadsheet with data but load instantly if empty. I tried all the solutions listed above. But found the solution by accident the other day when trying to find out why there is a delay between when I type and what appears on the screen. It fixed the excel problem too. Try this

In Cortana type 'services' then look for 'dmwappushsvc', right click, choose properties and disable. According to other forums this is a Microsoft key stroke logging software (can't confirm that myself). Anyway, this fixed my problem, hopefully it will do the same for you.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Ok so here was our issue and solution found. We had Dell Optiplex 7040 and 7050 boxes. These were deployed from inhouse tested images. 

7040 users had no issues with Excel

7050 users had slow opening excel docs unless Excel was already opened.

We tried all the things found online from Cortana, regedit hacks, etc...

We removed all programs but Win 10 and Office 2016 with all updates and latest drivers, with no luck.

What we did notice is if when the PC was 1st booted you could open a excel doc quickly and if you closed it and tried again it took the 30-40 secs to open it after that. So we looked at the programs at start up and disabled them all and rebooted.

After rebooting we found Excel was working perfectly all the time. So one by one we started enabling startup items and rebooting until we found one item that was causing it "Waves MaxxAudio service" which is part of the Realtek audio program drivers. 

So we uninstalled both of the Realtek programs

Realtek Audio Com Components

Realtek High Definition Audio Driver

Rebooted the PC and Excel worked right away and we noticed that the Realtek programs and Waves service reinstalled and everything was still working perfectly.

So my suggestion is if anyone is having this issue you might want to start with what is first booting up and disable them to see if that works, then you can start working your way through the list.

I hope this helps someone out there, as who would have thought a Audio program/driver would effect Excel this way?

22 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Unfortunately turning off Hey Cortona is not the answer, it is still happening to one of my clients. Any hotfixes as of yet?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Dell has now acknowledged that the Realtek card and Waves driver may cause this Excel problem on Dell workstations. http://www.dell.com/support/article/us/en/19/sln306701/slow-performance-issues-in-excel-when-opening...  I wrote up some instructions and background, if anyone is interested. http://www.brucebnews.com/2017/07/a-possible-fix-for-the-excel-slow-file-opening-bug/

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Bruce, I already caught that and explained how we fixed it.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

We tried all of the different fixes out there, but what fixed it for us was to uninstall the Realtek Audio Com Components application and the Realtek High Defninition Audio Driver applications (from Control Panel - Programs and Features).   Then reboot.  The audio drivers reinstall, but Excel works perfectly after.

We did this on about 4 Dell desktops recently to fix the same issue.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.