How do I get my .xlsm file to open by default in Excel 2016

I created a .xlsm file under Excel 2007. I have now upgraded to Excel 2016.  The file opens by default (from explorer) in Excel 2007.  I an open it from within Excel 2016, make changes to it and then save it, but if I open it through Explorer, it still opens under Excel 2007.  How do I get it to open in Excel 2016 by default?

Added info (11/02/2016 01:02 AM):

1.  I have responded to the two suggestions received so far Please see below.

2.  I think I have identified the problem.  A search of the registry shows that in HKEY_CLASSES_ROOT (when referenced by name) Excel Templates  are routed to Excel 16, but spreadsheets and macro enabled spreadsheets files are routed to Excel 12.  In looking at the file types, most of them appear routed to Excel 12.  There are several references to older versions of Excel that are not on this machine (and never have been). This is far too much to fix by hand.  Does anyone know of a tool that will straighten things out?

Addendum: 11/6/1016

Would I do my self any harm by uninstalling Office 2007?  Would this help fix the associations in the registry?

After opening the file in 2016, save the file using Save As Type Option and select the file format of 2016.

Do this once.

Next time it should directly open in 2016.

Excel is Awesome!! One problem always has multiple solutions.
If my answer solves your problem, please tick mark it as Answered.
Cheers RajeshC

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Terry, 

One option may be to right click on the file and select Open With, this may give you the option to select which version of Excel to use and then tick the box to make this the default.

Option 2: can you do a search in windows for Default programs  (normally under System - Settings)

You may then be able to find file type xlsm and associate Excel 2016 with it.

Option 3: The other less satisfying solution is to have Excel 2016 open before double clicking on the file in Explorer

Wyn

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

There is no separate type for Excel 16. The two main choices are .xlsx and .xlsm and it aleady is .xlsm
. . . . Terry.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Option1: The only option shown is Excel 16 -- it still opens in Excel 12.

Option 2: The defaults in the settings already show Excel 16.

Option 3: This works.  It also works to open it from within Excel 16.  These are not deemed as long term viable solutions.

Added Info (11/01/2016 11:50 PM): If I create new file (.xlsx or .xlsm) in Excel 2016 and save, it will still open in Excel 12 when opened through Explorer.

. . . . Terry.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Terry

Maybe this might help

https://support.microsoft.com/en-us/kb/2553378

which i sourced via this article 

https://support.office.com/en-us/article/Office-2010-and-Office-2013-side-by-side-eb569695-ce97-4841-831e-236f095f7803?ui=en-US&rs=en-US&ad=US

I'm pretty much out of suggestions after that.  

Let us know if you resolve it  

Wyn

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I solved the problem.

First, I uninstalled Office 12. 

I then found I could not open Office files at all by  double clicking on them in Explorer.  The error said I needed to have the Program installed.  The defaults for Excel were still version 16 and the files would open if I opened Excel first.

I then went into settings for Office 16 and selected the Modify/repair options.

This seems to have fixed everything and my Excel (and other) files open properly from Explorer.

Thanks to all of you for your comments.

. . . . Terry.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

To clarify the Settings path:

Start Bar / Settings / System /

I put office in the search box

Selected Office 365

Pressed Modify and then Repair

. . . . Terry.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated August 12, 2020 Views 5,176 Applies to: