I can't open excel files directly.

I have office 2010.  When I click on an Excel file to open it, Excel does not open.  "Microsoft Office 2010" tries to open it, but can't.  This seems to be a picture viewer as it comes up with any jpg's that are in the same folder as the Excel file I clicked on.  The icon for Excel files is not the usual icon, but one for a picture.  However, the file type is still xls or xlsx.  Macro-Enabled worksheets will open Excel by clicking on them.  The icon for these is the usual Excel icon but with a yellow exclamation point.  It doesn't seem to matter how I save them or which version of Excel they originate from.  Is there anything simple I should do to fix this, or should I just try uninstalling and reinstalling office?
 

Question Info


Last updated September 30, 2019 Views 27,001 Applies to:
Answer
Answer

Right-click a .xlsx file in Windows Explorer.

Select Open With > Choose Default Program... from the popup menu.

If Excel is listed, select it.

Otherwise click Browse..., locate and select EXCEL.EXE in C:\Program Files (x86)\Microsoft Office\Office14 or C:\Program Files\Microsoft Office\Office14 depending on the version, and click OK.

Tick the check box "Always use this program to open this kind of file".

Click OK.

---
Kind regards, HansV
www.eileenslounge.com

11 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

There might be some issues with the file association. Try the steps below to set Excel as the default application for the file type.

1)   Right click on one of the Excel files

2)   Click on Open with > Choose default program

3)   Now choose ‘Microsoft Excel from the list’

4)   Ensure to have a check mark in the box reading ‘Always use the selected program for this kind of file’

5)   Click OK

 

Refer the link below for more information about setting a default program for a file type.

http://windows.microsoft.com/en-US/windows7/Change-the-program-that-opens-a-type-of-file

10 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.