Excel changes dot of my keyboard to comma.

Excel always interpret the "." of my keyboard as ",". My regional setting are correct ("," is the decimal separator) and my keyboard layout is correct (FR-BE). I don't find how to change the behavior, specific to Excel (and Powerpoint) only. All the other applications use the actual keyboard key (".") but Excel uses instead the decimal separator from the regional setting. In my case, the sign on the numerical part of my keyboard is a dot, not a comma, so it's NOT a decimal separator. How to change that behavior ?
James
 

Question Info


Last updated November 18, 2018 Views 23,648 Applies to:
Answer

What is the operating system? Which version of Excel is installed on the computer?

You may try following these steps:

Excel 2000 – 2003: Tools Menu - Options - International Tab - Separators > check ‘Use System Separators’ > then click ok.

Excel 2007: Office button > Excel options > Advanced > Editing options >check the ‘Use System separators’ > click ok.

Click on Start > Control Panel > Clock, Language and Region (Regional and languages) > Change the date, time, or number format > Click on Additional settings button. This would display the Customize Format window where the Decimal Separator is defined.

51 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.