Office File associations

Recently we changed from Office 2003 Pro to Office 2010 Pro, for whatever reason, all .doc, .xls, and .pps files are not associated to any programs.  Is there a way to do this globally as opposed to having to touch each computer?
 

Question Info


Last updated July 3, 2019 Views 2,184 Applies to:
Answer
Answer

Checking for Click to Run is first thing to do. After that here are several different ways of fixing file associations

 

Just noticed, do you mean that you are having this problem on many computers? You will either have to fix your installation image, or do the required fix on each one, one at a time. You could also use a registry monitoring tool to track the changes made to one machine, then export the reg files and apply the reg files to the other computers.  Some 3rd party "uninstall" tool track all changes made to the registry.

 

 

For both types of installation start by doing a repair

Repair or Uninstall Office 2010 - http://office.microsoft.com/en-us/excel-help/repair-or-remove-office-2010-HA010357402.aspx?CTT=1

 

Cannot Set Word/Excel 2010 as default Program - CTR File Association

Quite simple really:

·go to programs and features

·go to office click-to-run

·right click

·click change (instead of uninstall)

·let the wizard do its thing and it should work.

If that doesn’t work, try replacing it with regular install.

 

Try repairing your Office installation to fix your file associations:

Repair or remove Office 2010 - http://office.microsoft.com/en-us/excel-help/repair-or-remove-office-2010-HA010357402.aspx?CTT=1

 

If that doesn't work, try:

 

Re-register the application

There are several different ways you can reset the proper file associations. Word itself provides a way to do it. Open a command prompt window and, at the command line, enter the following:

winword /r

Nothing seems to happen when you press Enter, but Word will reregister itself back in Windows. In the process, it resets the file associations for the files it uses, such as DOC and DOT files. You can close the command prompt window and double-click on a document; Word should start right up.

 

If that doesn't work, try:

 

Alternate Re-register the application

Close the app. Open the Run Window: <WIN> R, use the following command (Modify the Path to match your specific installation):

"C:\Program Files\Microsoft Office\Office\winword.exe" /unregserver

The quotes are necessary, but you may need to change the path so it reflects the location of the winword.exe file on your system. (You can use Windows’ Search tool to locate the path to the winword.exe file.) The /unregserver switch “unhooks” all the references to Word in the Windows Registry.

You should then, immediately, use the following command:

"C:\Program Files\Microsoft Office\Office\winword.exe" /regserver

This command causes Word to rewrite all its Registry keys and to reassociate itself with document and template files. Now you can double-click a document file and see if Windows starts Word and opens the document.

 

If that doesn't work, try:

This page has instructions, with pictures, on how to use builtin windows tools to fix file associations:

http://www.worldstart.com/how-to-set-defaults-successfully/print/

 

If that doesn't work, try:

There is a freeware tool called  Default Programs Editor. It brings many of the default settings into one place: http://defaultprogramseditor.com/

 

If that doesn't work, try:

 

Need to associate the file type with program:

In Windows 7:

  • Right-click the file,
  • Select "Open With" select [Your Program Here]
  • Check “always use this program”.

 

If that doesn't work, try:

 

Alternate method of associating file type with program:

  • Click Start
  • type cmd in the run dialog box then press ok.
  • On the command prompt line type "control panel" without the quotation marks.
  • In control panel > folder options > file types > new (button) in the new window click advanced.
  • In the file extension dialog box type the file extension to fix, ie: exe.
  • In the drop down menu locate and select application > click ok.

Sometimes one of these works when you're having trouble with double clicking on the file in windows explorer:

(xl2007) Office Button|Excel Options|Advanced|General|Uncheck "Ignore other applications that use DDE"

 

If that doesn't work, try:

 

Office 2010 in Win 7

A solution is:

·Start

·all programs

·Microsoft office (this gives the list of office applications)

·Right click on excel

·select 'properties'

·select the compatibility tab

·uncheck the ' Run this program in compatibility for:' 'windows XP service pack 3'

My excel files now open fine.

 

If that doesn't work, try:

 

Change the program that opens a type of file - http://windows.microsoft.com/en-US/windows-vista/Change-the-program-that-opens-a-type-of-file

 

If that doesn't work, try:

 

Fix File Association Error When Launching Windows Explorer in Win7 - http://www.winhelponline.com/blog/fix-file-association-error-explorer-in-windows-7/

 

If that doesn't work, try:

 

How to Set Defaults Successfully http://www.worldstart.com/how-to-set-defaults-successfully/print/

 

If that doesn't work, try:

 

Win7 Set Default and Use Open With & Always Open With Settings in Pictures- http://notebooks.com/2011/02/08/how-to-set-default-programs-and-use-open-with-and-always-open-with-settings/

 

If that doesn't work, try:

 

RestoreEXE File Association in Windows 7/Vista After Incorrectly Associating It With Another Program -http://www.winhelponline.com/blog/restore-exe-file-asso-windows-7-vista-incorrectly-associated/

 

If that doesn't work, try:

 

How To Change & Fix Broken File Type Associations In Windows 7 - http://www.makeuseof.com/tag/change-fix-broken-file-type-associations-windows-7/

 

If that doesn't work, try:

 

doubleclicking an individual excel 2010 file won't open it, can only open from the dropdown menu when office app is open-http://answers.microsoft.com/thread/2184f1b7-c13a-49a9-b1ed-f6a523d698cc (You shouldn’t have to do this, but if nothing else works give it a try)

 

.
A bus station is where a bus stops.
A train station is where a train stops.
On my desk, I have a Windows work station …
.
¯\_(ツ)_/¯
.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.