stdole32.tlb in Excel

I am running Windows 8, and I have just reinstalled Office 2007.  When I open Excel, I get a screen that shows stdole32.tlb and then office goes on to configure.  This happens each time I open up Excel.  How do I stop this?  I don't have the regedit function, that I used to have with prior versions of windows.
 

Question Info


Last updated December 6, 2019 Views 207,786 Applies to:
Answer
Answer

Hi Susie,

Thank you for posting in Microsoft Community.

 

In addition to Chip's suggestions you may also follow the steps mentioned below and check if it helps:

Try the steps mentioned below and check if it helps resolve the issue:

Important: Ensure to back-up the registry before changing the registry keys:

http://windows.microsoft.com/en-us/windows7/Back-up-the-registry

·         Go to Run (press Windows+R key on the keyboard simultaneously) and type regedit

·         Navigate to the HKEY_CLASSES_ROOT > Excel.Chart.8

·         Right Click on key and select Permissions

·         In the Permission windows > click on Add tab and add Everyone

·         Once this is done, click on the Advanced tab > Owner > highlight Everyone > click on Apply and Ok

·         In the Permission > select Everyone > enable the check box for Full Control and Read then click on Apply and Ok

·         Click on F5 to refresh, this should create a new Sub key below Excel.Chart.8 called Protocol > right click on the key and repeat step 3 – 5.

·         Refresh again and follow the same sequence of steps to add permission to the following Sub keys StdFileEditing >Server.

·         Close the registry editor.

 

You may also refer the link mentioned below which discusses about the similar error message and check if it helps:

http://answers.microsoft.com/en-us/office/forum/office_2007-office_install/stdole32tlb-file-missing/ba3e940d-d628-4334-ac89-5e8ac9878093

 

I hope the above suggestions helps to resolve your issue. If you need any further assistance reply and we will be glad to assist you.

Thanks.

368 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.