Access 2010 linked SharePoint 2010 list - Lookup column throwing "Cannot update. Database or object is read-only."

I'm at a total loss here...

I have a SharePoint contact list linked in Access. The list contains a Site Column, which is based on a lookup from a list at an upper-level site in the Site Collection hierarchy. Permissions are set properly across the board - regardless, I'm Owner on everything, and I'm having the problem.

If I remove the Site Column from the list, i have no problem updating records.
If I add the site column back in with no values, I can edit any column in the list, except the Site Column (which throws the error).
If I add the site column and add values into it via SharePoint site, I cannot make any changes to any columns in the record, or else it throws the error - unless the change that I make is to remove the value from the site column field; it will accept that change.

I have no problems making changes in the browser (SharePoint GUI).
I can make changes (in Access) to the list that is the source of the site column.
I can make changes to other lists on the same site that do not use the site column.
I have the same problem with other lists on the site that DO use the site column.
The site column is not based on a required field.

I am using Office 2010 SP1 and SharePoint 2010. I am a Site Collection Admin, but not a Farm Admin.

I swear this used to work, but now it doesn't. There must be some switch somewhere, or something, because I can't find too many people with the same problem by searching the web. When I do find someone with the same problem, it either turns out to be something slightly different, or it isn't answered. I actually even found one reply showing everything working properly (although I'm not sure that his lookup was a site column based on lookup).

Regardless, i don't think what I'm trying to do is unique; I'm trying to use these site columns and lookups, etc. I thought that's what they were for.

I could really use some help to figure out what I'm missing...

Thanks,

MR
 
Question Info

Last updated August 6, 2018 Views 6,497 Applies to:
Answer
Matt,

I was receiving the same exact error message with a similar problem. I was not able to update an "Attachment" field of a linked SharePoint List via MS Access Form, but all other fields, I could update/change just fine. It took me two weeks to figure out what the problem was. In File => Options => Current Database => Caching Web Service and SharePoint tables, I had to uncheck "Use the cache format that is compatible with Microsoft Access 2010 and later." This solved my problem. Hope this helps you out as well.

Brock

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.