Work anywhere from any device with Microsoft 365

Upgrade to Microsoft 365 to work anywhere with the latest features and updates.

Upgrade now

Access 2010: "There is no object in this control" error

Using Access 2010, I have one workstation (XP Pro) of 10 that gives me "There is no object in this control".  When I open the Access 2007.accdb in exclusive on the offending PC , none of the Listview or ImageList controls are recognized.   The other 9 PC's are a mix of Win7/WinXP Access 2007/2010 that have no issues.
 

Question Info


Last updated May 13, 2020 Views 27,115 Applies to:
Answer
Answer
Using Access 2010, I have one workstation (XP Pro) of 10 that gives me "There is no object in this control".  When I open the Access 2007.accdb in exclusive on the offending PC , none of the Listview or ImageList controls are recognized.   The other 9 PC's are a mix of Win7/WinXP Access 2007/2010 that have no issues.

I'd guess you have a broken reference on that PC.  On the offending PC, open the database, go to the VB Editor, and click Tools -> References... to look at the list of references.  Is any reference marked as MISSING?
Dirk Goldgar, MS Access MVP 2001-2015
Access tips: www.datagnostics.com/tips.html

20 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.