Why does my excel window lag so much when moved around the screen? no other app windows have the problem

When  I have excel open, even a tiny spreadsheet, and move the window around the screen there is severe lag. The window can keep moving around the screen for a few seconds after I have stopped moving the mouse. I am running windows 10 with all updates installed and Office 365 with all updates installed.

The lag gets worse when connected to an external high res monitor.

This problem does NOT occur with any other application window which can be moved around the screen as fast as I like with no lag.

I am running Surface Pro 3, i5 8Mb Ram with all updates installed.

 

Question Info


Last updated June 14, 2019 Views 10,689 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hello Everyone,

I have this problem on the computer that I am running a 144 Hz display (with nVidia G-sync).  I believe it is an issue with Windows trying to redraw the Excel window at 144 Hz while the window is being dragged around the screen.

If you try it on a computer without G-sync (normal 60Hz monitor) you probably won't get the issue but let me know.

*edit*  The other thing to check is the polling frequency of your mouse.  If you have a gaming mouse with 1000Hz polling frequency try changing it to 500Hz.  


-Brian


2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I just did a new system build, clean install, got excel, it worked fine for a few days.

Then today it started this window lag problem. and only on my new desktop, not my old laptop. I'm not sure whats going on.

This is an Excel problem, and it has been for a long time. It's related to the system tracking the virtual workspace when the window is moved (which is why turning off 'show window contents while dragging' sometimes helps). Eventually, there will be a fix - in the mean time, you probably won't get a lot of help here, other than the standard 'reboot your system', 'update your drivers', 'some other program/driver/device' blah blah blah. 

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It appears that the Microsoft workers quit trying to help solve the problem. Silence...

I have this same issue with my HP Windows 10 work laptop that I was issued a couple weeks ago. Excel is the only application that does this. Kind of like drifting your car around a mountain road. As an IT worker, I prefer to have my screens do what they're expected to do; leave the drifting to the car.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is not just Excel problem, for me this occurs also with Word 2016. Funny enough these are the only two applications that have this annoying issue.

It doesn't sound convincing that the root cause is monitor refresh rate or mouse polling rate. My reasoning for that argument is lagging occurs on my laptop that is using 60 Hz display and non-gaming basic business mouse which uses Windows' built in HID driver.

Also in some forum post I saw a comment where user said that feature update 1809 fixed this issue. At our office we have both 1809 an 1803 setups and issue happens in both.

Below some system details

Winversion: 1803 build 17134.556

Excel version 2016 MSO (16.0.4738.1000) 64-bit

OS - Name Windows NT 10.0; Win64; x64

OS - Architecture x86_64

OS - ProcessorModel AMD PRO A10-8700B R6, 10 Compute Cores 4C+6G

OS - NumberOfProcessors 4

Memory - Available 3003301888

Memory - Capacity 7963312128

Display - PixelsPerInchXaxis 96

Display - PixelsPerInchYaxis 96

Display - Height 1080

Display - Width 1920

Display - DevicePixelRatio 1

Cheers,

Matti Nousiainen - Sr Test Engineer & Quality Consultant

-Matti

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same exact problem.....I've read through some posts but didn't seem to solve anything. I definitely know that it is not a mouse nor monitor issue for me. I was curious if this problem ever got fixed?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This issue has not been fixed. You can change a mouse with lower reporting rate(low end optical mouse) to resolve the issue.

Cheers

Jacqueline

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I believe this will never get fixed as it is a design problem with the Microsoft Office window refresh code. I see the issue in Microsoft Word and PowerPoint but largely in Microsoft Excel. I recommend trying to disable the "Show Window Contents When Dragging". My computer is locked down and I cannot change the setting.

Sadly, I cannot figure out a good workaround to make this more acceptable.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I see the same problem. In my case, there is significant improvement when I set Power Mode to Best Performance. It goes worse in Battery Saver mode.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi there,

Did this ever get solved for you? I have had the same issues, mostly with Excel. Something that SEEMS to have helped this morning is a display setting change. Time will tell if it's my imagination / temporary or a real fix:

  • Right-click on the desktop and select Display Settings.
  • Scroll down and click on Graphics settings
  • There's now a dialogue that offers the ability to change graphics settings by App.
  • In the drop-down box I selected Universal app, then a second drop-down appears, ion which I selected Office and clicked Add.
  • Office now appears below as an icon. Click the icon and select Options.
  • From the three options of System Default, Power Saving and High Performance, I selected High Performance and clicked Save.
  • You may need to exit all Office apps before the new setting takes effect. I simply did a full restart of the PC to make sure of it (1TB SSD = quick restart :-) )

The Excel windows still have a small amount of lag, but not as bad as before.

I would be interesting to know if this helps anybody else.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hooray !! I have just tested my two pc's and the problem appears to have gone away, the Excel window can be dragged around the screen as fast as i like without any lag. I have not made any changes to my pc's / laptops configuration so I can only assume that  Microsoft has fixed the problem with one if it's many updates.

I will continue to monitor in case it returns.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.