Unable to map a Sharepoint network drive

I need to be able to edit and upload theme files directly to a sharepoint site, and according to the design manager instructions I can do this by mapping a network drive on my local computer to https://sitename.sharepoint.com/_catalogs/masterpage/

However when I try this I'm met with the following error:


The mapped network drive could not be created because the following error has occurred:

Access Denied. Before opening files in this location, you must first add the web site to your trusted sites list, browse to the web site, and select the option to login automatically.


I have done everything it suggests, but it did not fix the problem. I have also tried using the option 'Connect to a website that you can use to store your documents and pictures' but this gives me the following error:

The folder that you entered does not appear to be valid. Please choose another.


In this case I tried changing the URL to https://sitename.sharepoint.com/_catalogs/ and https://sitename.sharepoint.com/ neither of which worked.

I have made sure my login credentials are 100% correct and have tried mapping the network drive on multiple devices and multiple connections - which leads me to belive there may be an issue with the way this sharepoint site has been set up?

Is there any other way I can easily access and modify the theme files? If not, how can I fix this network drive issue?


Thanks

hi neilsmith,

about the issue, if you run into the error message below when mapping the master page gallery library to the local machine, could you try the following steps to see if there is any improvement?

1. log into the master page gallery library via the link you mentioned with the internet explorer browser and select the keep me signed in check box.
2. click the settings icon of the browser > internet options > security > trusted sites > sites. then, add the sharepoint site url into the zone. if it is already in the box, please remove it and re-add the url.
 
3. go to the master page gallery site and click library > open with explorer. copy the url in the window as below: https://contoso.sharepoint.com/_catalogs/masterpage .
 
4. please keep windows explorer of the library open and right-click the computer icon from the desktop or within windows explorer, and then click map network drive.
5. copy the url above into the folder box > finish.
 
6. then, we will get a network location as below:
 

in addition, to troubleshoot mapped network drives, i would like to share with you the article: how to configure and to troubleshoot mapped network drives that connect to sharepoint online sites in office 365.

if anything is misunderstood or the issue persists, please let us know and we will continue to discuss the situation based on the update.

regards,
shirley

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi NeilSmith,

Can you map a SharePoint network drive now? Do you need further assistance?

Regards,
Shirley

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The issue is authentication simply DOESN'T WORK IN O365. I keep reporting that here and in service requests and Msft keeps repeating the same boilerplate replies none of which address the underlying issue. Since everyone has this issue without exception it must have come up in what ever testing was done, but was never fixed. The above workaround will work temporarily but what we need is reliable, persistent connectivity not a workaround. Anything else doesn't meet the most basic standards of an "enterprise solution".  

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Shirley, I had this issue last year with clients of mine using Windows 7.  I seem to remember that the solution lies in Advanced settings of internet Explorer in that a protocol setting solved the issue of having to reconnect each time a restart occurs.  Maybe you can help me find that solution again as I have another client with the same issue.

Ian T

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Ian  - according to the recurring reports of this and related issues, it's not a browser or client side issue. Since it's so widespread and well known to Msft but has never been fixed, we can only assume that either:

It's intentional and designed to make it harder to hack into a SP tenant

Or, more likely, it's an issue that would require rewriting major chunks of SP to fix, which Msft doesn't want to do.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for the reply, but the SSL/TLS issue solved this for one of my clients running Win 7, I just cannot remember the precise process.  They have not had an issue since.  Because WebDav is used I guess that these settings then come into play in Explorer when mapping HTTPS sites.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Temple ton,

Thanks for your update.

Because similar issues may have different root causes, it is best to post a new thread with detailed information about the issue you encountered. Then, we can focus on the details of your exact scenario to provide one-on-one support.

Your understanding is highly appreciated.

Regards,
Shirley

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Wish I could be more helpful, but in the 6 years I've been using O365, I must have tried everything and there is simply no reliable, permanent fix. The authentication cookies last a finite amount of time (by design) and when they expire, mapped drives have to be recreated and trust has to be reestablished between local network locations and SP.  Your client may think they had a fix but I can assure they didn't,.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated September 18, 2020 Views 30,862 Applies to: