The "Extra Space After An Apostrophe" problem - solved?

This is a reply to all those who have have had this problem or is going to have this problem in the future.  I don't know if it will work for everyone.  But it did work for me.  And  even if it doesn't work for you it shouldn't hurt to give it a try anyway.

Actually I got this problem solver from one of you.  But I don't remember who it was.  Whoever it was I want to thank them again.

All I had to do to solve this problem is to 'select all' text.  And go to my font - and select it again.  That solved my problem.  I haven't had the problem since.

Sorry to be a dummie, but what do you mean by "go to my font and select the font again" ? You mean selecting the font again from the font picker drop-down, that doesn't work for me, not on Word 2016 anyway.

On my system the extra space after apostrophe only happens when using the Microsoft Yahei font though.

Actually what really fixed this issue for me is this:

I noticed this problem was not happening in other rich text editors, so I copied the strange "apostrophe & space" character from Word into WordPad, then typed an apostrophe next to it, also in WordPad. At that point I noticed that, even though neither apostrophe had a space after it, the two apostrophes looked different, so I figured they were not identical characters. It occurred to me that this might be related to Word's auto-correct feature and, indeed, there is an option that takes care of this. It's the smart quotes.

don’t

don't

An alternative solution, if you must use smart quotes, is to pick a different font. In my case I was using Microsoft Yaheij which was causing this problem. After switching to Microsoft Yahei UI the problem was gone (of course if I switch back to Microsoft Yahei the problem reappears). These two fonts look identical, but the "UI" variant doesn't result in the strange spacing.

I hope this can help someone.

This worked for me as well. Turning off smart quotes in the autocorrect options solved the problem.
Sorry, this still doesn't work for me. I have this problem ONLY when I change the text direction in a table cell from horizontal to vertical. I have tried the tip above, checked all the language settings, unchecked the default language option, tried selecting the word and using Ctrl plus the space bar, and verified that the font is installed. In fact, this occurs with all fonts under the conditions I described above, even the most ordinary ones. I am using Word 2013. And I can't believe that this problem has been going on since 2010!
This worked for me. Thanks so much!
 
 

Discussion Info


Last updated July 11, 2020 Views 32,554 Applies to: