Screen-sharing in Teams Mac, no ‘Windows’ or ‘Desktop’

Since yesterday, I am unable to share anything but PPTs in Team meetings with colleagues.

MS Teams 1.2.00.28258 on Mac 10.15 – since yesterday, I cannot share anything but PowerPoint files. The option to share ‘Desktop’ and ‘Windows’ have disappeared. I have checked the boxes in System Preferences > Security > Screen Recording.

Answer
Answer

hi all,  you have to go deep into preferences and allow the app to access your computer.  I know this isn't the best explanation, but I got it to work on my bosses computer.

This may be it:

  1. Click the Apple menu.
  2. Then, go to System Preferences > Click Security & Privacy > Privacy tab.
  3. Click Screen Recording.
  4. Click the lock icon to make changes.
  5. If required, enter your admin password.
  6. Finally, click the checkbox next to Microsoft Teams.
  7. notification window will ask you to restart it. Agree.
  8. Then, try again and see if the issue persists.

If not this, something very similar.

You are close to that you have to do, problem is for many that the 'approval' is there but doesn't seem to have any effect. It is as if the program is not paying attention to the approvals.

128 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated January 24, 2021 Views 56,827 Applies to: