RPC error when using PowerShell command Start-managedfolderassistant

I have enabled Online archive for a mailbox and in Powershell when I use start-managedfolderassistant -identity <user mailbox>  I get RPC Error as follows:

The call to Mailbox Assistants Service on server: 'CY1PR0701MB1932.namprd07.prod.outlook.com' failed. Error from RPC is -214
7220992.
    + CategoryInfo          : InvalidOperation: (:) [Start-ManagedFolderAssistant], TaskException
    + FullyQualifiedErrorId : [Server=SN2PR0701MB1008,RequestId=826c779b-f7a7-493f-8f09-8b448fd8960f,TimeStamp=10/2/2015 5:
   34:19 PM] [FailureCategory=Cmdlet-TaskException] C16BF700,Microsoft.Exchange.Management.SystemConfigurationTasks.StartE
  lcAssistant

I have successfully used the command in the last 1 week and have encountered the error in the past. I try couple of time and it works without error. Today , the error just will not go away.  Issues with Office365 servers?

 

Question Info


Last updated April 4, 2019 Views 2,455 Applies to:

hi mohan,

 

for such a situation, you can try restarting your windows powershell and check the result.

 

if the issue persists, i’d like to collect the following information for further troubleshooting:

 

1.    do you have on-premise environment? if so, run the cmdlet “mount-database” and check the result.

2.    if you create a new user account for testing, can the issue be reproduced?

3.    how many users have the same issue in your organization?

 

moreover, please upload a screenshot about the output of start-managedfolderassistant. to upload a screenshot: click “use rich formatting”> “insert media”.



 

regards,

alan


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The issue pops up often for many users. Being able to run the command without RPC error is an exception. Usually resolves in 3rd or 4th try. Here, I was unable to successfully run the managefolderassistant command all day. Since the user's mailbox was 99.8% full, we assigned 1 GB additional space to the mailbox and the script ran successfully. I am thinking that the error could have been due to either emails being uncompressed to move to archives and there was no space or because archiving process needs space in the users mailbox for managing the move and the mailbox was full. I will try a few more to see if adding space to the mailbox resolves the issue.

Thanks

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Mohan,

Then, we will wait for your testing result. If the issue is not related to the “space”, we are glad to provide the further assistance.

Regards,

Alan

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks Alan.  I have a premier support ticket open for the issue. I will provide update once we find out what the issue is.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Mohan,

 

Have you got the Service Request (SR) Number? I have sent you a private message to collect it so that we can monitor the case for you.

 

To access and reply to the private message:

1. Go to "Your details" section on the right side of the community site.

2. Click Private messages.

3. Click the subject title of the response to read the message.

 

Regards,

Alan

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Mohan,

I have found the status of the SR is closed, do you have any update about it?

Regards,

Alan

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Maybe my colleague closed the SR after we found a work around trying various options. First we make sure that the mailbox has 1 GB free space. Then assign Retention policy to the mailbox and enable archiving . Wait for 5 minutes and then run Start-managedFolderassistance command. It works.

Following the process noted above works well. Not seen RPC errors again.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.