Outlook 2019 not connecting to gmail

I'm having a problem connecting my gmail to Outlook 2019 - it won't download emails or sync the account. I'm attempting to set up a new laptop with Windows 10 and several other email accounts have been set up fine; Windows Mail also downloads the gmail account fine but I'd like them all in one place as I've got Outlook from Office 365. My previous laptop is still downloading gmail to Outlook 2016 so the settings in gmail are such that it allows imap.

I get all the way through the automatic setup - logging in to gmail with the 2-step authentication - and allowing it to access my account, at which point it comes up with an error message saying ' Sorry, we could not sign you in to Google - IMAP. Please try again later.'

I've tried:

- most combinations of gmail port numbers and encryption settings (SSL/TLS, STARTTLS)

- turning off 2-step authentication in my gmail settings

- using an app-specific password to login

- taking the gmail account off Mail

- several restarts

- running Windows updates

Any advice?

***Moved from: Apps on Windows 10 / Mail/Outlook Mail***

Answer
Answer

I managed to solve this by turning the 'Share Connected Experiences' option on in my Office account as per comments here and here. The full comment is: 

What did work for me is Janice Reid's solution (https://support.google.com/mail/thread/5567190?msgid=5865463)
Go to Outlook > File > Office Account > Account Privacy > Manage Settings > All connected experiences > Enable connected experiences. Check the box. Close Outlook, re-open it.
Change Account Properties > Server settings and re-enter your password. Since I have 2-step security, I had to use an App password I created in my Google Account > Security > Signing in to Google > App passwords. Then follow the prompt to login to the Google Account, do the 2-step security thing, give Microsoft access to your account. Then it worked again as it used to.

BONUS: Then I went back to Outlook > File > Office Account > Account Privacy > Manage Settings, I disabled connected experiences, restarted Outlook, and my Gmail still works! Apparently connected experiences is only needed during the Google login setup process?!... Who knows, but personally I would rather avoid more "connected experiences" than the minimum required.


27 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated July 1, 2020 Views 4,643 Applies to: