Outlook 2019 keeps asking for password - Triggered when signing in to Office Account or adding another account

We have Office ProPlus 2019 VL Outlook version 16.0.10340.20017 x64 running on RDS. This is a new deployment so it's a fresh clean RDS with new profiles. Email is hosted by Office 365 and not on-prem.

Problem is Outlook started asking for password when we added another email account of the same domain. It would be OK after signing in for the entire session but upon logout and logging back in, it keeps asking for password. This only happens to users with additional account - i.e. Own email + Accounts@ or something.

I have tried all suggestions from all places in the forums - clearing Password cache, Windows Credentials, Registry key fixes and Autodiscover to no avail.

Test 1:

I did a test creating a new profile using the same account which works fine on its own. But when I added another account, everytime the user logs in and starts Outlook, it prompts to enter password.

Test 2:

2nd round of test creating a new profile using the same account. This time without adding another account but then I logged in to Office App Account - found in File > Account > User Information. This also triggered Outlook to keep prompting to enter password.

Any recommendations is much appreciated.

Hi Arvvie

I'm so sorry you are facing issues!

My name is Margarida, I'm an Independent Advisor Specialist on Microsoft. We are experienced users who assist the Support Staff by helping out fellow users in the community.

To help with this question, a higher level of access is required to preform the required technical analysis.

I recommend that you start a chat with a live specialized outlook support agent.

To do so please:
- Clicl here: https://support.microsoft.com/en-us/contactus/o...
- Select product "Outlook"
- Select issue "Technical Support"
- A new page will automaticallu Open
- Then click on chat.

Hope this helps!

Thank you, have a great week!
Margarida

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Fixed it. With more persistence testing so many different scenarios, I've narrowed it down to:

Solution 1 Scenario: New Profile or start from scratch (delete old user profile)

1. Before starting Outlook to add any accounts, add the following registry entries:

[HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity]
"DisableADALatopWAMOverride"=dword:00000001
[Computer\HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Autodiscover]
"ExcludeExplicitO365Endpoint"=dword:00000001
"ExcludeHttpsRootDomain"=dword:00000001

2. Then add the email accounts as usual.

Note: I've also noticed with "DisableADALatopWAMOverride", I didn't see any "Allow Organization manage this device" or something similar - but it works!

Solution 2 Scenario: Existing User Profile (too many reasons not to delete existing user profile)

I managed to save more time by not recreating the users profile as I had three others experiencing this issue with large profile data by keeping the current users environment intact by doing this:

1. Add the following registry entry on current device and profile:

[HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity]
"DisableADALatopWAMOverride"=dword:00000001
[Computer\HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Autodiscover]
"ExcludeExplicitO365Endpoint"=dword:00000001
"ExcludeHttpsRootDomain"=dword:00000001

2. In Computer\HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity\Identities, delete all identities that correspond to the email address and not the @domain.local_AD

3. In Credentials Manager > Windows Credentials, delete all the Generic Credentials relating to Office16.....

4. Start Outlook and enter your password. Then close.

5. Log out of existing profile.

6. Then on the same device, create a new fresh new user profile by logging in with a new user account that has never logged in to that device before and add the following registry entry:

[HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity]
"DisableADALatopWAMOverride"=dword:00000001
Computer\HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Autodiscover
"ExcludeExplicitO365Endpoint"=dword:00000001
"ExcludeHttpsRootDomain"=dword:00000001

7. Then add the email accounts as usual. Go back to your existing profile and don't log out of the new profile and sign in as a different user and sign in as the existing user.

8.  Start Outlook and magically, this fixes the password prompt.

With so many logouts and logging back in since applying these fix, cross fingers the issue of Outlook asking for password everytime it start hasn't come back.

To apply the fix on the next user you provision, you can also add this to your GPO User Configuration > Preference > Windows Settings > Registry so that a new user/profile created will apply this fix prior to creating the new Outlook profile and email account.

Hope this helps someone.

ArielSE

18 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated January 13, 2021 Views 11,411 Applies to: