MS Word - How to change the language for a Table Style

When editing a Table Style, there is no option to change the Language. So my question simply is, how do I change the Language for a Table Style in MS Word?

I am creating a document template, so the answers given to this problem are not an option because it would involve repeating the actions every time a document was created from the template, or relate to the Windows version of Word

Notes:

  • ALL other styles (including Normal) have the correct language. It is only this table style that has the problem.
  • I am using MS Word version 19.19 (181109) Office 365 subscription (Mac OS)

 

Question Info


Last updated December 5, 2018 Views 75 Applies to:

Hi RedNectar.Chris,

Thank you for posting your concern in our forum and we are sorry for the inconvenience. However, the language attribute is not included in a Table Style or a List Style.

The workaround can be:
1. Manually select the table then go to Review > Language to change the one you want.
2. If you don’t want to change the table language manually, you can change the default proofing language to be the same as the one you want to set for the table style, then save the file as a document template. The table style default proofing language will follow your template's default proofing language.

If you still have concern, we suggest posting in Microsoft Word UserVoice for the related team to know your demands.

Regards,
Justin

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Justin,

Thanks for taking the time to reply.

I have to disagree with your statement that 

the language attribute is not included in a Table Style or a List Style.

because my screen dump shows a Table Stylte that has one!  It's just not available to us to edit/change

And I'm sorry that the workarounds don't work either. Because I'm not trying to change any particular table, I'm trying to build a template. There are no tables in the template itself - it's just a blank document with a set of attached styles.

And of course, I already tried suggestion #2 - it didn't work.

So Option #3 (MS User Voice) might be the only option.

RedNectar
(aka Chris Welsh)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

A Table style adopts the language with which the Normal style is formatted.
Hope this helps,
Doug Robbins - Word MVP
dougrobbinsmvp@gmail.com
Screen shots by Snagit from www.techsmith.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Doug, 

Firstly thanks - I do appreciate you taking the trouble to reply.  And for a brief moment I thought that maybe I didn't need to worry about the stupid language setting for the table.

But when I tried by

  1. Checking that the default language was set to English (AUS)
  2. Adding a table and applying my Table Blue Style

I found that the table had taken on the Language of the Table Blue Style - i.e. English (UK) as shown in my original post.

Exhibit #1: Language Settings for the Normal Style:

Exhibit #2: Language for first cell in Table is English (UK) - NOT the "the language with which the Normal style is formatted."

So I'm still stuck with this stupid setting.  One day I'll get around to deleting it and re-creating it, but I'm a stubborn person, and believe that if the Language CAN be set, we mere mortals aught to be able to change it!

RedNectar
(aka Chris Welsh)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Chris,

Sorry that it doesn't work for you and thank you for pointing that statement out. What we meant was the ability to edit the language in a Table Style.

Also, you're right, as this is currently not available, posting in Microsoft User Voice is the best option for now.

Regards,
Justin

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

You need to set the language in the Normal style BEFORE defining the Table Style.
Hope this helps,
Doug Robbins - Word MVP
dougrobbinsmvp@gmail.com
Screen shots by Snagit from www.techsmith.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

You need to set the language in the Normal style BEFORE defining the Table Style.
Bit late for that!!!  The Table Style is already defined. I need to change it.
RedNectar
(aka Chris Welsh)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.