Microsoft Office 2019 High CPU Usage after installing an Update

Hi eve ryone

i have a problem with my Microsoft Office 2019,

After updating ms office to version 2005, then it use very high power usage (usually not)

My hardware is Intel Core i7-9750H with 16GB of RAM, i assume microsoft office will not use very high of power usage 

Update 10/06/2020

Thank you for answering my question

I have found the solution, just uninstall ms office, the install office again with offline installer.

i think, microsoft click to run will use high power usage if you use ONLINE installer or if you update ms office with online connection

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi FaizalIndra,

I'm Jen, an Independent Advisor and a Microsoft user like you. Thanks for reaching out.

Sorry to hear about your troubles regarding high CPU usage after installing an update. You share the same issue in this thread, https://answers.microsoft.com/en-us/windows/for...

1. You can perform disk cleanup, see this link, https://support.microsoft.com/en-us/help/402661...

2. You can also do clean boot. See this link, https://support.microsoft.com/en-us/help/929135...

You can also get useful tips from this reference.
https://fossbytes.com/how-to-fix-high-ram-and-c...

Note: This is a non-Microsoft website. The page appears to be providing accurate, safe information. Watch out for ads on the site that may advertise products frequently classified as a PUP (Potentially Unwanted Products). Thoroughly research any product advertised on the site before you decide to download and install it.
@J.A.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hello,

I have the same problem. Office 2019, after the automatic update of Office to version 2005, has the same issue: the CPU usage for each Office application (30-35%) is far above normal (usually 1-3%) on my Win10 Intel i5 machine.

The problem affects the behaviour of each Office 2019 application and of the service Office ClickToRun (SxS). That service showed a CPU use of 35% too. It can be terminated, but it will show again (hourly, the service seems scheduled); if disabled, Office applications do not even launch so it cannot be disabled. Even after termination of the ClickToRun service, the CPU usage for each Office application remains higher than before version 2005, even if each Office application is idle.

I tried to disable the Office automatic update: the problem seemed resolved, however, the very next day Office started to trouble again.

Matteo

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Update:

- I disabled the Office 2019 automatic updates;

- I disconnected the Internet connection (Internet not avalable);

- I rebooted the Win 10 system;

- I launch the Office 2019 applications.

Office 2019 does not found an Internet connection running, then Office 2019 runs at normal pace (CPU usage 1-3%). That's it. Wow.

If I reconnect to Internet and launch an Office application again, the Office CPU usage goes to 35% for each Office application, stable, and the laptop overheat.

The issue is clearly related to Office 2019 version 2005 update: since the automatic update, if any Office application is launched with the internet connection available, the CPU usage goes sky high. I wonder what is going on.

It seems quite weird to me...but so far it explained what I saw in the last days post version 2005 update: if launched without internet connection, Office 2019 runs low on CPU again, as normal.

Could someone verify the statement? Thanks

Matteo

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I had the exact same issue

Any office application would cause very high power usage, individual CPUs would hit 100% at random and cause the fans on the laptop to go through the roof.

Opening outlook in safe mode - caused the issues as well.

Opening Excel, Word etc without any files loaded and in safe mode, also caused the issue.. There are no 3rd party addins on this at all.

I have decided to use the office customisation tool to roll back, as i cannot use a laptop that is about to over heat at any moment.

I went back to Monthly Enterprise channel as that might cause a little bit of time for the issues to impact other people before getting to me!
No on version 2002 without any problems!

I too have similar hardware, 16GB ram and i7-9850H, i am running the 64bit version of the app.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi

I am also having this problem. 

Any update on a solution?

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I started having this problem right after updating last week.  I found the following post:

https://answers.microsoft.com/en-us/msoffice/forum/all/version-office-365-outlook-1601282720200-high-cpu/7c6f52bd-3a83-47c2-97b8-c41c173c8d99

and then started a post of my own:

https://answers.microsoft.com/en-us/msoffice/forum/msoffice_officeinsider-mso_win10-msoinsider_outlook/version-office-365-outlook-1601282720200-high-cpu/eea63b8e-eac5-45fc-9822-6cf241bea083?tm=1591372977865

I haven't rolled back yet.  I am hoping that Microsoft will push out a fix within a two week period so that I don't have to roll back.  I am also hoping that Microsoft reads these posts and realize that they have pushed a problem out and that they have fixed it in a faster track version and get that version out to us on the slower track.  If they don't, I will roll back and wait.

This doesn't help you, but maybe it adds to the weight for MS to move on this problem.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Other link

My post

My apologies, for not creating the links.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

The solution i used was to roll back to a earlier version.

I then chose to set my PC to enterprise release channel for MS office updates, so i wont be involved in the current range of bug testing

Download the office customisation tool and extract it to a folder, i used c:\office365

https://www.microsoft.com/en-us/download/details.aspx?id=49117

Use this config file to download office but limited to a slightly older update

in text form at the end..

Then run c:\office365\setup.exe /download config.xml

While this is doing this download, remove current office.

Then when finished run

C:\office365\setup.exe /configure config.xml

Make sure setup.exe file and config.xml are in the same folder.

Save the following as config.xml

Starts here ****

<Configuration ID="c887094f-1170-42d9-9310-8676e807bde5">

  <Add OfficeClientEdition="64" Channel="MonthlyEnterprise" Version="16.0.12527.20612">

    <Product ID="O365ProPlusRetail">

      <Language ID="en-us" />

      <ExcludeApp ID="Groove" />

      <ExcludeApp ID="Lync" />

      <ExcludeApp ID="Teams" />

      <ExcludeApp ID="Bing" />

    </Product>

  </Add>

  <Property Name="SharedComputerLicensing" Value="0" />

  <Property Name="PinIconsToTaskbar" Value="TRUE" />

  <Property Name="SCLCacheOverride" Value="0" />

  <Property Name="AUTOACTIVATE" Value="0" />

  <Property Name="FORCEAPPSHUTDOWN" Value="FALSE" />

  <Property Name="DeviceBasedLicensing" Value="0" />

  <Updates Enabled="FALSE" />

  <RemoveMSI />

  <AppSettings>

    <User Key="software\microsoft\office\16.0\excel\options" Name="defaultformat" Value="51" Type="REG_DWORD" App="excel16" Id="L_SaveExcelfilesas" />

    <User Key="software\microsoft\office\16.0\powerpoint\options" Name="defaultformat" Value="27" Type="REG_DWORD" App="ppt16" Id="L_SavePowerPointfilesas" />

    <User Key="software\microsoft\office\16.0\word\options" Name="defaultformat" Value="" Type="REG_SZ" App="word16" Id="L_SaveWordfilesas" />

  </AppSettings>

  <Logging Level="Standard" Path="c:\temp\officelog.log" />

</Configuration>


1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thank you, I noticed that there are other users having the same problem.
I spoke to Support today, they said I need to uninstall and reinstall.

Please MS, get this fixed, I am not sure, but I think this is not healthy for my laptop.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have this problem (Excel and Word tested) only when my ethernet connection (USB tether) is metered. My workaround to start an Office app:

1. Connect network and turn off metered connection

2. Run Excel/Word

3. Turn on metered connection

Although tedious, it might be an alternate to rolling back

Seems like the app tries to do something which is blocked by metering, and then doesn't time out trying. Running in Safe mode and not even opening a file causes high CPU ~25% per Office app.

Office 2019 installed.

Excel 2005 (Build 12827.20268 Click-to-Run)

Excel 2019 MSO (16.0.12827.20200) 32-bit

Windows 10 Pro 64-bit

Version 1809

Build 17763.1217

Standard user account

27 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated November 16, 2020 Views 3,488 Applies to: