Incomplete email sync from Gmail into Outlook for Mac

I've been using Outlook for Mac (version you can download as of today from office.com, which is version 16.37) to manage my email from Gmail (G Suite account).

Mac is operating on Catalina 10.15.5

A couple of days ago I noticed some missing emails in Outlook, so I wanted to re-sync. Based on online research, I deleted the Gmail account within Outlook and then re-added. Many emails synced, but not all. I tried this several times.

I also tried things like: re-booting Mac, deleting Office entirely from Mac and then re-downloading and re-installing. Still, when I add the Gmail account I get an incomplete sync.

IMAP is enabled in Gmail.

Does anyone know why this happens and if there are more things to try?

Thanks!

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Fizzystik,

 

According to my research, if these two preferences are available for your e-mail service and you select it, Outlook automatically updates your IMAP folders continuously. you can try to enable these two preferences in IMAP account server settings to see if it helps. To access these settings from the primary IMAP Account preferences dialog box, click the Advanced button, and then click the Server tab. Turn on Sync all IMAP folders every __ minutes and Use IMAP IDLE if the server supports it. See IMAP account server settings get more info.

Besides, because of the data limitations with Google, if your Gmail mailbox is too big, the initial download of your entire mailbox to Outlook for Mac may take up to a few days for older messages to become available in Outlook. For more information please see Known issues syncing Google accounts to the Microsoft Cloud

If the problem persists, please post back to us with the screenshot of the email in your Gmail mailbox and in Outlook client. we would love to help you here.

Regards,

Grace

-----------------------

* Beware of scammers posting fake support numbers here.

* Kindly Mark and Vote this reply if it helps please, as it will be beneficial to more Community members reading here.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Grace, thanks for your response.

I don't see how to access the primary IMAP Account preferences dialog box. I'm not using Outlook for Mac 2011 or 2016. It is Outlook for Mac Version 16.37. When I go to Outlook->Preferences->Accounts there is no Advanced button.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Fizzystik,

 

Thanks for your reply.

 

As your Outlook version cannot find the Advanced button, I would like to share with you some customers experience when other customers meet the same issue and they contacted the tech support of Outlook for Mac, here is the answer:

“I contacted support,  was told the delayed sync behavior I am observing is the expected behavior. Gmail is synced first from my Gmail account to the Microsoft Cloud, and then from the Microsoft Cloud to Outlook on my Mac. This all takes a while and is responsible for the delay.

Support said it was possible to manually configure Outlook on Mac to directly receive my email from Google via IMAP, without using the Microsoft cloud, which would solve my problem. However, if I did that, I would lose the ability to sync my Google calendar and contacts to Outlook.”

 

If you still have other concerns, to better user experience, I suggest you contact our Outlook for Mac dedicated team support to obtain further assistance. Click “?” button then click Contact support in outlook.

 

Regards,

Grace

-----------------------

* Beware of scammers posting fake support numbers here.

* Kindly Mark and Vote this reply if it helps please, as it will be beneficial to more Community members reading here.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Fizzystik,

Are there any updates you would like to share?

Regards,

Grace

-----------------------

* Beware of scammers posting fake support numbers here.

* Kindly Mark and Vote this reply if it helps please, as it will be beneficial to more Community members reading here.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks, Grace. In terms of these two ideas:

1. It is not a matter of delay. After several days it has not fully synced.

2. I don't know how to "manually configure Outlook on Mac to directly receive my email from Google via IMAP, without using the Microsoft cloud." But in any case, I would not want to lose calendar sync.

Unfortunately, I am settling for an approach where I toggle back and forth from Outlook client to Gmail browser.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Fizzystik,

Thanks for your update.

In this case, to better user experience, we would recommend you contact the tech support of the Outlook for Mac to see if it is related to your outlook problem.

Also, it is likely related to your Gmail account data problem, you said you lost emails when you using G suite account in Outlook, please try resync or repair Outlook data with your G suit account, contact the G suite account support to see if resynchronizing data will resolve this issue.

Thanks for your support and cooperation.

Regards,

Grace

-----------------------

* Beware of scammers posting fake support numbers here.

* Kindly Mark and Vote this reply if it helps please, as it will be beneficial to more Community members reading here.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Is there any update on this?  I am having the exact same problem, and based on my review of other posts, a lot of other people are too.  Starting last Monday, my emails will not sync when I am not using Outlook.  They come in on gmail.com and on my iphone and ipad, but they will not sync to Outlook. What normally happens is when I login in the morning, all of the emails that I received overnight do not sync to Outlook. All new emails will sync while I'm using Outlook, but the emails that came in overnight will not sync, although, oddly enough, sometimes they will eventually sync if I click archive and then undo on gmail.com (I guess to force the emails back into the inbox). I have tried removing gmail from Outlook and then adding it back several times, but that did not work.  I tried uninstalling Outlook entirely and downloading it again from Office365, but that did not work.  I also saw other posts indicating that people were getting emails with <no subject>.  I am also getting those too, usually tons of them when I removed gmail and added it back.  

This is getting extremely frustrating. Clearly, there was an update or something to Outlook that screwed this up. I also agree with the post above that there is no advanced tab on the accounts page.  I've seen several Microsoft personnel suggest checking that, but it's not there anymore (I believe an oder version had this). This is what we see when we go to the accounts section under preferences.  There are no options to modify anything other than what you see here.

I am running Outlook for Mac version 16.38 and Catalina 10.15.5. Is there a way to go back to an earlier version of Outlook?  It was working fine forever and then just stopped last Monday. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi AndreaSchroepfer,

To protect your private information safety,  I have removed your email address, thanks for your understanding.

For how to go back to an earlier version of Outlook on Mac, it is not feasible. To assist you further, we recommend you contact the tech support of Outlook for Mac, they have more resources about it. Click “?”button then click Contact support in outlook.

Regards,
Grace

-----------------------

* Beware of scammers posting fake support numbers here.

* Kindly Mark and Vote this reply if it helps please, as it will be beneficial to more Community members reading here.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have clients with the same issue. This is not a one-off.

Outlook for Mac version 16.38 (20061401)

G Suite users

Configuring the account using the native Gmail account addition function in Outlook has this behavior. When adding an account this way you do not have any of the advanced IMAP settings since it uses an api specific to Gmail I assume.

If you choose 'Not Google/Gmail?' when adding your email account, you can then add via the traditional IMAP way. This seems to pull in all mail, but does not allow for full calendar sync with google. IE: shared google calendars. So now the user has to choose, either they are missing email or calendar functionality.

Apple Mail does not have this behavior. This is a problem with Outlook for Mac specifically. Please fix or provide a fix ASAP.

Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Follow-up...

Initial testing of Insider Fast build 16.39 (20062305) seems to have resolved the missing mail issue when adding a Gmail account using the native functionality.

I went through the release notes before installing this build and found the following from the June 8th build...

"Google accounts: Improved functionality for Google IMAP accounts, including calendar sync via CalDAV"

https://support.microsoft.com/en-us/office/outlook-for-mac-release-notes-for-insider-fast-builds-d6347358-5613-433e-a49e-a9a0e8e0462a

Still reviewing, but this resolved a 'missing mail' issue so far and a '<no subject>' issue on another machine so far. YMMV.

To get this build, just "Check for updates" from the help menu of any Office app.

Click Advanced.

Choose the "Insider Fast" update channel.

Close the advanced settings.

Click Check for updates and install all or just Outlook.

Once installed, remove and re-add your Google account from Preferences-->Accounts and let it sync.

**Once the insider build is installed and working (hopefully), you can change the update channel back to Production. This will keep your current 'Fast' version installed and prevent auto-update from updating every time there is a new Fast channel release.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated July 14, 2020 Views 263 Applies to: