Work anywhere from any device with Microsoft 365

Upgrade to Microsoft 365 to work anywhere with the latest features and updates.

Upgrade now

How to change semicolon to comma when saving CSV file

Hi, I am using Excel 2016 and whenever I save my excel documents as CSV UTF-8 or other CSV option on excel they are usually semi colon divided instead of the comma I wanted. the setting is default and I have no idea how to change to comma. Please help

Try the following:

Select File > Options > Advanced.

Clear the check box 'Use system settings'.

Set 'Decimal separator' to a point (dot), and 'Thousands separator' to a comma.

Click OK.

Export to CSV.

Select File > Options > Advanced.

Tick the check box 'Use system settings'.

Click OK.

---
Kind regards, HansV
https://www.eileenslounge.com

58 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello,

Changing the comma to semicolon when saving a CSV file is easy. Here's how:

  1. Click on the Start menu.
  2. Type control panel.
  3. Click on Control Panel (Desktop app).
  4. Select Clock, Language, and Region.
  5. Click Region.
  6. Select Additional settings in the pop-up window.
  7. Change the List separator to comma.
  8. Click Apply.
  9. Hit OK.

Once done, try saving your CSV file and check if you will see comma instead of a semicolon.

Hope this information helps you. In case you need further assistance, don't hesitate to post back.

84 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.


  1. Click on the Start menu.
  2. Type control panel.
  3. Click on Control Panel (Desktop app).
  4. Select Clock, Language, and Region.
  5. Click Region.
  6. Select Additional settings in the pop-up window.
  7. Change the List separator to comma.
  8. Click Apply.
  9. Hit OK.

NO!!! DON'T DO THAT!!!

This affects the behavior of all programs on your machine and will have unpredictable effects.

It can even cause the individual programs to stop working!

Andreas.

58 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated July 7, 2020 Views 58,445 Applies to: