How do I turn off READ ONLY permanently???

This question was asked by someone else back in 2016, but none of the responses are relevant - maybe because I'm using Word for Mac. Can anyone help? I'm sick of office locking my files to Read Only.

I have files I use all the time in my one LOCAL folder, I'll open one and word decides it is Read Only and to make a change I need to save it as a new name.

Whenever I close the file (same happens in Excel), then reopen later, even if I open it again immediately... now its Read Only.

How do disable this frustrating **** interfering with my workflow?  It's making me crazy!!!

|

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi I am an independent advisor and hoping to help you today.

I am sharing a link below from the community, may I know if you already tried the suggested fix in the thread?

https://answers.microsoft.com/en-us/msoffice/fo...

Hope this helps.
Thank you.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks for the reply, but I've tried those responses.

The files I'm talking about have not been sent by email, neither have they been stored in the cloud / online. These are files stored locally on my OWN COMPUTER -- no one else is accessing them other than me, which makes this problem even more infuriating. I simply go to my 'recent' files (or find the files in my Finder - Word or Excel) and they open as READ-ONLY.

So i have to do this crazy work-around every single time i close and open a document to 'unlock it'.

Crazy!

Sorry to get worked up, but it seems to be a pretty fundamental error.

3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi, I am Joan an Independent Advisor and a Microsoft user hoping to help you today.

To the best of my knowledge, that cannot be done.
It's a "feature": the message bar will always appear, by design.

The reason is that so many people ran into trouble with this: Most would work on the document in their email, and then wonder why they "lost their changes" when they re-opened the document.

Sometimes, people who know better have to suffer to protect people who should know better from themselves :copyright: John McGhie

Thank you.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

To the best of my knowledge, that cannot be done.
It's a "feature": the message bar will always appear, by design.

Thanks Joan,

I guess you're responding directly to the title of my question, "How do I turn off READ ONLY permanently???" (which i copied from the old post i found - i thought it might trigger a response because it was an old question still not answered).

I guess I don't really care if i can turn it off permanently, especially since -- from what you say -- it was probably designed for people who are opening Word documents within emails, or making changes with docs being sent etc etc.

But MY PROBLEM REMAINS, and it is even simpler (and more troubling) than that, as outlined here:

  • I am NOT sending/receiving my Word doc
  • I am simply saving and closing my Word doc on my local hard drive
  • When i re-open the doc (either from the 'Recent' files in Word OR by double-clicking the doc in Finder on my Mac) it opens as READ-ONLY
  • NOTHING that i can find in settings anywhere can be changed to stop this happening

What am i doing wrong?
OR

What settings can i change so i don't have to fight the read-only work around?

6 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I see, I also apologize for that.

Another thing has been observed that Excel files get automatically read-only if you have used a “/” symbol while saving the file. Removing the slash symbol will fix read-only Excel Mac problem.

Microsoft Excel also has a built-in setting to set and clear read-only option, make sure it is turned off if you want to disable protection. This is how to remove read only Excel Mac easily:

Step 1: Open the Excel file, for which you want to disable Read-Only.

microsoft excel mac preferences
Step 2: Click “Excel” on the top menu.

Step 3: Click “Preferences” option, it will open a preference menu.

microsoft excel mac preferences window
Step 4: Click “Security” under “Sharing and Privacy” heading.

microsoft excel mac preferences security
Step 5: You will see a new screen where you can clear “Read-only recommended” checkbox.

Step 6: Now save the file and exit the program.

Let me know if this works.
Thanks.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks Joan,

There are definitely no / slash symbols in my filenames. The other suggestion you make is not there. I have the 'Security' tab as you list in step 4:

but when i select 'Security', I don't get any options relating to 'Read-only recommended' that you mention in step 5:

I feel like we're getting close to an answer though!!
:-)

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi, I am Rodel an independent advisor and I would like to help you to resolve your issue.

Please follow this steps.

1. Right-click on the file you need and select ‘Get info’ from the list.

2. Click the lock icon at the lower portion to make changes.

3. Enter your password and click ‘Ok’.

4. Select the account you want to give access to.

5. Set Privilege to ‘Read & Write’.

6. Click on the lock to save the changes.

I hope this will help. Please let me know if you need further assistance.

Thank you.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

OP did you resolve this problem in the end? I think I know why this is happening - it's to do with the additional folder security that was added in Catalina - as documented here: https://www.howtogeek.com/443611/how-macos-catalinas-new-security-features-work/

When I use 'Open Recent' to open something in Office that isn't saved either in my Documents or Downloads folder, it opens as Read-Only every time.

You can work around it by navigating to the file in Finder to open it, or by moving the item into your Documents Folder (not saying either of these should be acceptable solutions on a long-term basis.)

Hope that helps.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi

This is a problem caused my Mac OS Sandboxing security features.

If you use Suitcase to manage your fonts, version 9 or newer of Suitcase app fixes this problem. If you are using Suitcase, install Suitcase updates.

Apple provides a special location for you to safely store your user files. This article explains how to find that location for PowerPoint. There is a corresponding location for Microsoft Word and Excel.

Linked files require additional permissions - PowerPoint for Mac

I am an unpaid volunteer and do not work for Microsoft. "Independent Advisors" work for contractors hired by Microsoft. "Microsoft Agents" work for Microsoft Support.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I've seen a bunch of different threads around issues with things being opened as read-only on Mac. I think there are several different (though possibly related) issues going on.

One thing is clear, which is that if I save a Word or Excel file in a location other than Documents or Downloads (or some subfolder of either), if I open it via the 'Open Recent' list, it will open as read only every time. If I move it to the Documents or Downloads folders, the problem immediately goes away. If I move it back, the problem reappears.

It seems pretty obvious from the above that this is related to macOS's file system access restrictions. The first time an app tries to access the Documents or Downloads folders you'll be prompted to allow or deny, but the same mechanism doesn't exist for other folders. There's a 'full file system access' permission, but I don't think you can manually assign it.

Regardless, it shouldn't be necessary to go digging around looking for the relevant sandbox folder - surely it would make more sense to just save to your Documents folder?

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated September 14, 2021 Views 11,343 Applies to: