How do I get 'before' spacing to work after a column break?

So I'm working on a document that is divided into 3 levels. The first 2 levels are just section and subsection titles in a single column format. The third level is the body text, formatted into 2 columns. The 'before' spacing of the first column works, but the second column just sticks to the continuous section break, regardless of what value I enter, and even when i add a column break to the end of the first column. Below is a visualization of what I mean.

Column 2, which I've circled yellow, is where I'm having the problem:

Has anyone else suffered from this? Does anyone know a way around it?

Thanks!

|

Hi Jack,

This is best handled using a Frame.
Space Before Heading at beginning of page - Using Frames

Space-before formatting, by design, does not work following a page break or column break. Using a frame as part of the style gets around this.

I hope this information helps. Please let me know if you have any more questions or require further help.

Regards

 
Please mark helpful or answered as appropriate to help other users.

Charles Kenyon
Attorney at Law
Madison, Wisconsin
wordfaq[at]addbalance[dot]com

http://addbalance.com/usersguide/styles.htm

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Word 2010 and earlier have a Compatibility Option, "Suppress Space Before after a hard page or column break." By default, this option is not enabled in those versions. Unfortunately, Word 2013 and above enable this option by default and don't give you a choice. So the only (simple) recourse you have if you want this to work (and I ignore kludges such as adding an empty paragraph) is to save the document in Word 2010 format. This is not an option that Word provides in the Save As dialog; it requires a simple one-line macro (courtesy of Jay Freedman):

  1. Press Alt+F11 to open the VBA editor.

  2. Press Ctrl+G to open the Immediate window at the bottom of the editor.

  3. In that window, paste this line and then press Enter:
    ActiveDocument.SetCompatibilityMode wdWord2010

  4. Close the VBA editor.

  5. Go to File | Options | Advanced and scroll to the bottom.

  6. Change the dropdown "Lay out this document as if created in" to "Microsoft Word 2010". At that point, the list of 2010 Layout Options will appear below the dropdown.

If the "Suppress" option is enabled, disable it. Your document will be in Compatibility Mode, and you will not be able to use features introduced in Word 2013 and above, but that may not matter for this particular document.

Microsoft MVP (Word) since 1999
Fairhope, Alabama USA
http://ssbarnhill.com
http://wordfaqs.ssbarnhill.com
Screen shots captured with TechSmith's Snagit

3 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Parallel columns (compared to snaking newspaper-style columns) are better handled as (borderless) tables. You would not have this problem with tables.

Please mark helpful or answered as appropriate to help other users.

Charles Kenyon
Attorney at Law
Madison, Wisconsin
wordfaq[at]addbalance[dot]com

http://addbalance.com/usersguide/styles.htm

1 person found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated July 2, 2021 Views 805 Applies to: