How do I change the default date format on Excel for Mac to DD/MM/YYYY

I've been incredibly frustrated by this. I live in Europe and my standard date format is DD/MM/YYYY. So when I type in 01/05/2018 I expect Excel to show that or 1 May 2018. But it inverts it to MM/DD/YYYY. 

I've looked at many forum threads with similar questions but all I find is temporary and not full solutions. I've tried changing the format to DD/MM/YYYY but it only changes how the date is displayed so there is a discrepancy between how I type it and how it is shown.

I have all my computer settings to DD/MM/YYYY but Excel doesn't seem to be inheriting these.

Please help! What to do?

Answer
Answer

The default formats used by Excel for Dates, Times & Numbers is determined by the macOS System Preferences for Language & Region. Your message suggests that you may have made those changes, but was Excel running when you did? If so you must restart the program in order for the changes to go into effect.

While Excel is not running go to > System Preferences. Specific verbiage may differ based on your version of macOS but from there it should be simple to recognize the equivalent Language & Region pane in order to get to the Advanced options. The preferred format must be made for each of the four Date styles: Medium, Long, Full as well as Short.

Note: Just to clarify, even doing this correctly will not cause the dates in existing workbooks to display differently than when they were entered.

AI: Artificial Intelligence or Automated Idiocy???
Please mark Yes/No as to whether a Reply answers your question.

Regards,
Bob J.

22 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated July 30, 2020 Views 4,774 Applies to: