Emails sent from Outlook in Citrix session are getting stuck in the outbox of the local copy of Outlook

Hi there,

We have a very strange problem where email messages sent from Outlook launched from Citrix are not being sent and are getting stuck in the outbox on the local client version of outlook. This doesn't happen all of the time but we have been able to reproduce the problem in the following way

Outlook is closed in Citrix session and on the local pc (confirmed by checking task manager and citrix director) open document with say word or Excel using the citrix version of the application, select File "save and send" enter recipients of the email and click send, email disappears and looks to have been sent, Outlook is still closed in Citrix and on the local PC.

Recipient doesn't receive the message, the message is not visible in Message trace on Office 365, the message cannot be found by E-discover on Office 365, I give myself permission to the users mailbox, the message is not visible in any folder when viewing the mailbox in outlook web app or local or citrix outlook.

If the affected user opens the local copy of outlook the message is immediately sent and can be viewed in message trace, e-discovery and arrives with the recipient. If outlook on citrix is opened the message is not available and is not received, the recipient can be a shared mailbox or user mailbox. I have confirmed he message is stuck in the local Outlook outbox by having the user reproduce the issue and disconnecting the PC from the network before opening the local copy of outlook and checking the outbox. 

outlook version is 2010 on citrix and pc using Office 365, in Citrix online mode is used, local PC client has outlook cached mode enabled, both are set to send immediately when connected, outlook is not set to work offline and shows as connected at all times.

The issue has been going on for some time, Initially we thought thata local copy of Word or Excel was being launched and  sending the messages to the local cached copy of outlook then sitting in the outbox due to outlook being closed, this is not the caase. It has been suggested that users should leave the locally installed outlook open at all times however this is confusing for many users as they have been told to use citrix for all applications

I have worked with Office 365 support and have confirmed there is no delay on the Office 365 side as the first time Office 365 message trace 'sees' the stuck message is when the user launches the local copy of outlook and the message is delivered to the recipient, we have confirmed that the message is in the local outlook Outbox.

If you have got this far thanks for sticking with me, any help or advice is much appreciated.

Hi Cara,

To better assist you, kindly answer the following questions:

  • Have you tried running the Office Repair?
  • Have you tried sending Outlook emails outside Citrix? Were you able to send emails?
  • When you logged in to Outlook.com, were you able to see the emails in the Outbox folder?

We look forward to your prompt response.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello,

We have run many repairs on Office, have re-installed office and have transitioned to a different citrix environment (all citrix servers were replaced with new 2012 servers) and replaced a number of PCs we have also reproduced this issue on multiple machines to confirm there isn't a "bad" citrix server, or just a wonky PC. we have created many new mail profiles on both the PCs and in the citrix environment.

When people use the local version of outlook and the pc is connected to the network the message is sent immediately. 

when we logged on to outlook.com the stuck email was not visible in any folder, junk, outbox, sent items or drafts. The only way we could view the stuck message was by opening the local copy of outlook with the network disconnected, if we were to open the local copy of outlook with the network connected the message will immediately send and be received by the recipient.

We've also checked that the users haven't inadvertently set delay delivery in outlook which they haven't. The issue is rather intermittent, our save and send example is the only way we have been able to reliably recreate the issue on demand. When users have reported the issue its in the form " I sent an email on Monday but the recipient only received it on Wednesday" by the time the recipient has received the email, Message trace says its seen the mail on Wednesday there is no delay on delivering the mail and the mail is no longer stuck.

From our troubleshooting it looks like even though send Immediately when connected is set in outlook the message is not sending immediately at times from outlook in citrix but is synchronizing to the outbox in the OST file on the local PC. 

Many thanks

Cara

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

To further isolate the issue, how were these emails configured? Were they setup as IMAP or POP3?

Regards.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

All of our users are using RPC over http to connect to Office 365.

Many thanks,

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

As an additional update, we have tested opening the local copy of outlook, minimizing this and using save and send from Citrix, the message was sent immediately and receieved as expected. A number of users won't be happy at having to keep a local copy of outlook open so would rather not have to use this as a work around. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have tested using the save and send option from MS word via citrix on a PC that doesn't have any locally installed MS office products. The email is immediately sent and received as expected by the recipients. This causes me to think the issue is either O365 or Outlook and not a Citrix issue as the problem only seems to happen when there is a local installation of MS office on the PC which is being used to access Citrix.

Our users have reported that the issue occurs intermittently (emails sent from citrix are either not received or received after a delay of hours, days or weeks) the problem is not specifically the save and send feature it is that using save and Send from Office applications in citrix is the only way we have been able to replicate the issue on demand. Normally when we are infromed of an instance of the issue it is when the email is delivered to the recipient after some delay (being stuck in the local Outbox) at which point O365 message tracking shows no delay in message delivery and the message is no longer "stuck".

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Kindly sign in here; then observe if the same issue may persist.

Regards.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks Vanessa,

The isuse does not occur when we use the web login for Office 365. we've issue does not occur in the following circumstances:

1. the user has the locally installed copy of outlook open at the same time as using outlook through Citrix.

2. the PC the user is logged on to does not have a locally installed copy of outlook and they use outlook ONLY through Citrix.

3. Outlook is being used through Citrix, there is a locally installed version of outlook on the PC but the user does not have a profile configured on that machine.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

We suggest that you also reach out to Citrix support, they might have some solutions on their end as well. As per case isolation, there might be some configuration in Citrix that is needed to be modified to have the issue be resolved.

Regards.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks Vanessa,

I will raise this with our Citrix team again and have something logged with Citrix.

Many thanks,

Cara

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated August 10, 2020 Views 2,602 Applies to: