Disable download from library files - Sharepoint Online

Hi I would like to disable the download from library files (mp3 files). How can I achieve that? I also have access to Azure. Thank you

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Marie-Neige Beaudoin-Guerin,

 

Do you want to disable the Download option for the files in a library for a user? If yes, you may just share read only permission for the files with the user.

 

Best Regards,

Tina


--------------------------------
* Beware of scammers posting fake support numbers here.
* Kindly Mark and Vote this reply if it helps, as it will be beneficial to more community members reading here.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi for all visitors, how do I do it?

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Marie-Neige Beaudoin-Guerin,

 

You may create a new SharePoint group and set Read-only permission for this new group. Then add all visitors to this group. Then share the library with this group.

 

1.Create a new SharePoint group with read-only permission.

Go to site settings>Users and Permission>Site Permissions>Create Group, enter the Name>in Give Group Permission to this Site, select View Only>click Create.

 

2.Open the new group, add all visitors to this group by click the New>Add users to this group.

 

3.Go to the library, go to Library settings>Permission and Management>Permission for this document library>Stop inheriting permissions>Grant Permissions>Invite people>enter the name of the new SharePoint group.

Click SHOW OPTIONS, select View Only and click Share.

 

Note: Ensure visitors don't have edit permission. If visitors are in another SharePoint group with edit permission(such as the member group), please remove that SharePoint group from the library permission page. Select that group>click Remove User Permission from ribbon.

 

Here is an article for your reference: Customize SharePoint site permissions:

Customize permissions for a SharePoint list or library

 

Best Regards,

Tina

--------------------------------
* Beware of scammers posting fake support numbers here.
* Kindly Mark and Vote this reply if it helps, as it will be beneficial to more community members reading here.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi, this is not a solution because "view only" visitors can download. It is even specified in the description. 

"Lecture - Afficher des pages et des éléments de liste, et télécharger des documents." = "View - Display pages and list elements, and download files". 

All my visitors are already View only. I want to disable file downloads. Thank you!

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Marie-Neige Beaudoin-Guerin,

Thanks for your update. We are now doing investigation, we will post back as soon as there is any update.

Best Regards,

Tina

--------------------------------
* Beware of scammers posting fake support numbers here.
* Kindly Mark and Vote this reply if it helps, as it will be beneficial to more community members reading here.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Marie-Neige Beaudoin-Guerin,

 

Sorry for the late response. I have test from my side with the following steps, you may have a look and see if they help you:

 

Note: this way only works when you are using SharePoint modern experience. The Download button still exists when you using SharePoint classic experience.

 

1.In the SharePoint site, create a new permission level which doesn't have the Download button from the library.

Go to Site permissions>Advanced permission settings>in the site permissions page, click Permission Levels>Add a Permission Level, create a new permission level having the following permissions:

2.After create the new permission level, go to the library which contains your pm3 files.

1)Go to Library Settings>Permission for this document library>Stop Inheriting Permissions>select all existing SharePoint groups and click Remove User Permission to remove them from this library permission.

2)Click Grant Permission, in Invite people, enter Everyone except external users and other external users(if you need to share the library with external users).

Click SHOW OPTIONS on the bottom, select your new permission level and click Share.

Then check if your users can see Download button when they access the SharePoint library.

 

Best Regards,

Tina

--------------------------------
* Beware of scammers posting fake support numbers here.
* Kindly Mark and Vote this reply if it helps, as it will be beneficial to more community members reading here.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi! Thank you for your easy to follow procedure, I followed exactly as you specified and strangely there is still the download option when I browse the library. I am the owner but I removed owner persmissions for the library.  In the autorization level, I don't see any option anyway regarding the downloading of library files. Oh and I really hope I didn't send a email invitation to everyone in the organization, I followed the instructions and I am not sure if I unchecked it...!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Marie-Neige Beaudoin-Guerin,

 

I suggest you go to the library permissions page, click Check Permission from the ribbon, check your permission and other users' permission. Ensure the user only has been assigned that customized permission and doesn't have any edit permission.

 

Based on my test, if a user only has the specific permission I created which doesn't have download permission, he won't see the Download button in the library.

 

When I check a user's permission of the library:

(the permission level No Download is the customized permission level I created)

When the user accesses the library, he cannot see any Download button for the mp3 file.

If above doesn't help, please share screenshots below for troubleshooting:

1.A screenshot of a user's permission of the library.

2.Please open the library, go to Library settings>Permissions for this document library, then capture a screenshot of the permissions page.

Thanks for your time and effort.

 

Best Regards,

Tina

--------------------------------
* Beware of scammers posting fake support numbers here.
* Kindly Mark and Vote this reply if it helps, as it will be beneficial to more community members reading here.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi yes there is no other permission. the unique permissions are just files that were shared. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Marie-Neige Beaudoin-Guerin,

 

Thanks for posting back.

 

Since you can check the library permissions, you have edit permission for the library, so it is expected that you can see the Download button for the files.

 

"Everyone except external users" is a specific group that doesn't have mailbox, so when you share the library with the "Everyone except external users" group with the unique permission, users won't receive any email invitations.

 

There should be no Download button for the files when users access the library.

I suggest you use a user account to access the library and check the outcome, or you may give the Library URL to one of your users and let him access that library to check the outcome.

 

Best Regards,

Tina

--------------------------------
* Beware of scammers posting fake support numbers here.
* Kindly Mark and Vote this reply if it helps, as it will be beneficial to more community members reading here.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated September 17, 2020 Views 14,501 Applies to: