Copy (Cmd+C) causes spinning beach ball delay for 3-4 seconds

Hello,

I'm back with the same problem again in Office 2019 -- I posted about this exact problem before (link) and it was never resolved.

The bug is that when hitting Cmd-C to copy a cell, the app will freeze / get stuck and the spinning beachball pops up for a few seconds. Then, after the delay, all is fine again. It makes working very tedious.

Mostly seeing this in Excel but it honestly affects ALL apps including Word, Outlook etc.  I thought it was due to a Clipboard History app I used to use called Pastebot, but I removed that a long time ago and the problem has re-surfaced so this is something specific to Office. NO OTHER APPS ON MY SYSTEM ARE DOING THIS.

This is also a brand new computer, a 2018 Mac Mini with high specs:

- Core i7 6-core
- 32GB RAM
- 1TB SSD
- Mojave 10.14.2

I have reproduced this with the Release track as well as Insider Fast v.16.21 (181219)
Is there anyone at MS that can look into why this is happening??
 

Question Info


Last updated September 21, 2019 Views 220 Applies to:
Answer
Answer

(even though this was marked as the "answer" the problem is not resolved, please read the rest of the replies and click the links to the UserVoice posts and vote for them if you face this issue and want it to be seen by the devs, thank you)

Ok - more info & making progress...

I tried the "shift boot" (Safe Mode) just to see if it would make any difference (it didn't by the way). BUT luckily this also disabled all my startup items... normally I use an app called Bartender which hides extra menubar items to reduce clutter. Without this running, the Bluetooth icon that I usually keep hidden was instead visible.

Now, when I copied out of Excel, I noticed the Bluetooth icon changing to "communicating/linked" mode. This got me thinking that the bug was related to Universal Clipboard. Which would explain why sometimes this bug doesn't happen (probably when my phone is off or not in range of the computer).

Lo and behold, I disabled Handoff (from System Preferences > General) and voila, the beachball when copying was gone instantly. Disabling Handoff is the only way currently to disable Universal Clipboard.

So, while this is NOT a real fix (since now I can't use Handoff, Universal Clipboard etc) at least it's a clumsy workaround for now. I also submitted this detail to Microsoft using the frowny-face. Hopefully whatever is causing this bug can be looked at and fixed on Microsoft's end. Again, this bug ONLY affects Microsoft Office apps...

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.