Chart with data labels will not copy to clipboard

Title pretty well says it. I have a workbook with multiple sheets and had noticed that I was unable to copy and paste charts from one sheet in particular. Initially I was trying to duplicate a chart (in order to change the data set slightly and compare) and was unable to Ctrl+C, Ctrl+V. Also could not copy/paste elsewhere (i.e. Word). Right clicking shows the option to copy (or cut), but it didn't seem to make it to the clipboard. Further investigation (opening the clipboard in excel) showed that it was not in fact making it. What was strange was that I could copy other charts from the same workbook (different sheet) just fine. In trying to determine what the difference could possibly be, I noted that the problem charts all had data labels. Sure enough, removing the labels fixes the problem. However, I want those labels when I paste the chart into Word. Current workaround is to paste as a picture. Labels were custom, but same problem exists with non-custom (eg. using the Y-value as a label).

Office 365 for Windows 10.

 

Question Info


Last updated November 11, 2019 Views 261 Applies to:

Hi D_B_rown,

 

We’re sorry for the inconvenience caused.

 

According to your description, when we tested at our end by copying the chart with data labels and tested by pasting in the Word documents and Excel applications. We can paste the copied chart without any problem.

 

Steps we had followed at our end:

1. Open the Excel application> Blank Workbook> Enter some sample data> Insert Chart> Check the Data Labels option

 

2. Tried copying the chart in both ways:

a. Right-Click on the Chart> Copy> Check whether it copied or not, by expanding the Clipboard in Home tab.

                                         

                                                     or 

b. Select the Chart> Click the Copy in Clipboard> Check it appears when Clipboard is expanded.

 

 

3. After Copying, pasting in the both Word document and Excel Worksheet (in same workbook)

 

 

Result is same either using Ctrl + V or Paste in Clipboard.

 

So, we guess that problem is not about the data labels, to move further can you try the following and provide us the result:

1. As you mentioned, you can copy and paste the charts without data labels, can you add the data labels to other charts and check whether copy and paste works without any problem? It also narrows whether the problem is with specific chart or not.

To add the Data Labels: Click on the Chart> Chart Elements (icon with +)> Check the Data Labels.

2. Can you create another chart in the same Excel sheet using the same data and check whether it works? If no, copy the data into new Excel workbook or Excel worksheet and check by inserting the Chart.

It narrows whether the problem is with specific sheet or workbook.

 

3. Can you open the Excel in Safe mode and check whether it functions without any problem.

Click Windows key + R> Enter excel /safe> OK

 

Note: There is space between excel and /

 

 

After trying the above suggestions, please let us know the result and provide the screenshot of your Office Account Page (Open Excel> File> Account).

 

Thanks,

Chitrahaas

-------------------------------------------------
If you feel a reply works for you, please kindly vote or mark it as it will be beneficial to other community members reading this thread.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi D_B_rown,

Haven't heard from you for while. Please let us know the information and result to help you further.

Thanks,

Chitrahaas

-------------------------------------------------
If you feel a reply works for you, please kindly vote or mark it as it will be beneficial to other community members reading this thread.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Upon further experimentation, the issue occurs with any chart where the data labels are coming from a custom, non-sequential range of cells (i.e. if my data labels are cells A3:A8,A12:A15,A28:A32). Does not seem to be specific to any given chart/sheet/workbook. I've not tried running in safe mode

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi D_B_rown,

 

Thanks for writing back to us and appreciate for more testing.

 

We would like to know whether the problem occurs in specific Excel file or not? If yes, please provide the Excel file to us by uploading it to your OneDrive and share us the link to access it.

Note: if the Excel workbook consists of personal information, please share us it via private message to protect your personal information.

 

In addition, try opening in the safe mode and provide the screenshot of the Office Account Page. (Excel> File> Account).

 

Thanks.

Chitrahaas

-------------------------------------------------
If you feel a reply works for you, please kindly vote or mark it as it will be beneficial to other community members reading this thread.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi D_B_rown,

After checking the asked information, let us know the result and information to move further.

Thanks,

Chitrahaas

-------------------------------------------------
If you feel a reply works for you, please kindly vote or mark it as it will be beneficial to other community members reading this thread.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.