Can't login to Teams on webb or Windows app


I just changed to a new Windows 10 computer and set it all up fresh from start. 

I've connected it to my business account and all, got the Office apps to work but not Teams. 

I've downloaded the MS Teams app and istalled it but when it freezes when I've entered my credentials and began to login. I've uninstalled it and restarted the computer, it's the same. 

Tried to login to the Teams webb and then I got in a loop when I enter my credentials the text in the addressbar begin to flip and after a while I'm back to the screen
Pick an account 
We couldn't sign you in. Please try again.

And I can see my usual work account.. Press it and then I get back to the same screen in a while.
Tried to press login to a different account and enter my credentials again, but no, same issue. 

I tried different webbrowser, edge, Ie 11 and Chrome, same issue.. 

Any ideas? 



Hello Tegon,


We’re very sorry for the issue you are having. According to the error message “We can’t sign you in. Please try again”, it’s a general error and the root cause can differs. I suggest you may try following steps to narrow it down:


1. Firstly, please login Office 365 portal with your account, navigate to My Account-> Subscriptions, just to make sure your account has been assigned Teams online licenses:




2. Clean up Teams and Office related credential caches in Windows Credential Manager:




3. Please check if there’s any third-party anti-virus running on your PC, temporarily disable it, as some ant-virus may block Teams traffics. Also try restarting PC to see if issue is related with memory caches.


4. If convenient, switch to a different network, as some network environments may have configured access rules that may blocked Teams traffics. Besides, I’d like to confirm with you whether you’re using Home, or Work network, and whether it’s directly connected to the Internet, or through a proxy?


5. Try to add Teams related endpoint to Trust site and check if this way can make any difference:


In the Internet Options window, click Privacy and then Advanced.

Select Accept for First-party Cookies and Third-party Cookies. Also, select the Always allow session cookies check box.


In the Internet Options window, click Security -> Trusted Sites -> Sites.

Add all the following sites:








If you have any feedback, please feel free to let me know, I’ll try my best to provide assistance.


Best Regards,



* Beware of scammers posting fake support numbers here.

* Kindly Mark and Vote this reply if it helps please, as it will be beneficial to more Community members reading here.

10 people found this reply helpful


Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.


Question Info

Last updated September 11, 2021 Views 23,819 Applies to: