Autocorrect doesn't work with contractions?

If I create an autocorrect entry that changes, for example "doest'n" to "doesn't" or "cat'n" to "can't" -- it simply never works. The entry is created all right, but when I actually type the wrong spelling, it simply puts a wavy red underline beneath it. It doesn't correct it.

I've actually noticed this problem in Word 2011 as well, btw, and was hoping it would be gone in this preview.

Any ideas?

Thanks.

|

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I agree with you it has never worked and is not working in the new Office for Mac preview also. This might be fixed in the full version release, but i am not 100% on this.

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I'm not sure what may be causing the problem for you & Arshad' Khan, but as you can see from this screen shot all seems to work as expected in Word 2011:

I don't recall ever having had an issue of this nature with the feature, itself. It works fine here in the Word Preview as well.

Exactly what steps are you taking to create the AutoCorrect Entry?

AI: Artificial Intelligence or Automated Idiocy???
Please mark Yes/No as to whether a Reply answers your question.

Regards,
Bob J.

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

It works fine for me as well in 2011 and 2016.

Does you AutoCorrect setting look exactly like these?

________________________________
Richard V. Michaels
info@greatcirclelearning.com
Provides free AuthorTec add-ins for Mac & Win-Office. Site: greatcirclelearning.com

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

To go along with Bob's answer

Add to AutoCorrect 

This movie was made on Word 2011, but steps are same or similar on  2016 preview.

_________

Disclaimer:

The questions, discussions, opinions, replies & answers I create, are solely mine and mine alone, and do not reflect upon my position as a Community Moderator.

If my reply has helped, mark accordingly - Helpful or Answer
Phillip M. Jones, C.E.T.

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Very interesting. When I manually add the Autocorrect entry from the Tools menu it works.

The problem only occurs when I right-click a misspelled contraction and then choose to Autocorrect it from there. Strange -- because the entry does then show up in the Autocorrect list. But there's obviously some kind of problem.

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

What language are you using? Does the style you are using have a language setting on it?

AutoCorrect libraries as well as your Spelling Dictionary are language specific and that might account for this anomaly. However with that said, it would seem if either were out of sync with your document style that you'd be having more than just problems with contractions. Worth a look and see though.

________________________________
Richard V. Michaels
info@greatcirclelearning.com
Provides free AuthorTec add-ins for Mac & Win-Office. Site: greatcirclelearning.com

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Well, now that I know what you're actually doing :-) I find that I can reproduce it in both Word 2008 & 2011... Haven't bothered with Preview but I'm sure it persists there. I've honestly not seen any reports of the same issue & I guess I've never attempted to add a contraction myself. I've further found that even using the Add to AutoCorrect in the Spell& Grammar window fails in the same way... the item is added to AC but doesn't function.

Please use Help> Send Feedback in Word 2011 and/or the Smiley @ the right end of the Tab bar in Preview to submit this to Microsoft. I'll submit a bug report as well.

AI: Artificial Intelligence or Automated Idiocy???
Please mark Yes/No as to whether a Reply answers your question.

Regards,
Bob J.

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Sounds good. Thanks to everyone for their help.

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I believe your problem is associated with the conversion of a straight quote character to a curly quote. The AutoCorrect is trying to work before the conversion from straight quote to curly quote--but the AutoCorrect entry for the contraction includes a curly quote. As a result, there is no match.

Try turning smart quotes off. You can do so in Word 2011 using Tools...AutoCorrect...AutoFormat as You Type menu item by unchecking the checkbox for "Straight quotation marks" with "Smart quotation marks". Once you have done this, you can now type the misspelled contraction, select it and create the AutoCorrect entry. After creating the AutoCorrect entry, you can turn smart quotes back on--and the misspelled contraction will be corrected automatically as desired.

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Your assessment is right on, Brad... Turning off Smart Quotes does make a difference, but unfortunately that really doesn't resolve the issue for at least 3 reasons:

  1. It relegates the user to not using curlies for the sake of the occasional need to add a contraction to the ACL,
  2. It imposes straights for all quotes (single & double), commas & semicolons, &
  3. Moreover, I'm not coming to the same conclusion :-) Even if you turn them off only for the sake of creating the entries, when they're on again what you type in a document will have a curly but the AC replacement will have a straight - at least that's what I see here.

IMO, the mechanism's failure to handle contractions when added by way of the contextual menu or the Spelling & Grammar check window still constitutes a bug. FWIW, Win Word appears to have the same shortcoming.

AI: Artificial Intelligence or Automated Idiocy???
Please mark Yes/No as to whether a Reply answers your question.

Regards,
Bob J.

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated September 2, 2021 Views 916 Applies to: